aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2016-08-19 12:25:34 +0200
committerMatteo De Carlo2016-08-19 12:25:34 +0200
commit80ded4461b6bcd1a2228a5b6daa10300e6b34fdb (patch)
tree2c032b037696d32805326d46d62407a97739b8bb /PKGBUILD
parentab963f5f90fb92e493e1791eeb8987d3cadef5cf (diff)
downloadaur-80ded4461b6bcd1a2228a5b6daa10300e6b34fdb.tar.gz
update to linux 4.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89aec56c251c..7d2c9f7b2c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-covolunablu-gaming # Build kernel with a different name
_srcname=linux-4.7
-pkgver=4.7
+pkgver=4.7.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -17,8 +17,8 @@ conflicts=('steamos-xpad-dkms')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -32,8 +32,10 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
sha256sums=('5190c3d1209aeda04168145bf50569dc0984f80467159b1dc50ad731e3285f10'
'SKIP'
- 'ce14aa1bcfa1b5d31d764cc1d6eb6a6fa8cebed3cf3e5c3aa5494b6a29c1e849'
- 'af91d71c4d7fdeed1e120e82e8f9860529d73340e6d896dacd6838f6d45bb72a'
+ '838fa595436fbf9f70759aa43c1cacd83cc0adc95d166648c1625ebd50fad04e'
+ 'SKIP'
+ 'daa4311ae89761fec6172d89e5314f40ce3f03476a8de9311a78eb909628b53a'
+ '53d42d95e6fb62fcaccebba5fd471a63503a74c74ca618bee0cb8b6b659614f3'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'a6bd81bbb2f72cfd6ad992fdeff4bac1cb7c58a8edfc3fcd76c1d7275f73d284'
@@ -54,7 +56,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git