aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoberto Benfatto2021-08-14 04:37:02 +0200
committerRoberto Benfatto2021-08-14 04:37:02 +0200
commit89bdbfc813704d3fa9906403cf104a94f4bc1899 (patch)
tree85e40cb5e9897944be16aa89957d715511ad1753 /PKGBUILD
parenta6236b7d9d302cf242edc57f72c06b793265fa47 (diff)
downloadaur-89bdbfc813704d3fa9906403cf104a94f4bc1899.tar.gz
Bump kernel version to 5.13.10, now using tkg futex2 patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 7 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5667eab156b6..9337440889ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jan Alexander Steffens (heftig) <jan dot steffens at gmail dot com>
pkgbase=linux-covolunablu-gaming
-pkgver=5.13.8.arch1
+pkgver=5.13.10.arch1
pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -21,17 +21,7 @@ source=(
"$_srcname::git+https://github.com/archlinux/linux?signed#tag=$_srctag"
config # the main kernel config file
bfq-default.patch
- 0001-futex2-implement-wait-and-wake-functions.patch
- 0002-futex2-implement-vectorized-wait.patch
- 0003-futex2-implement-requeue-operation.patch
- 0004-futex2-documentation.patch
-# 0005-futex2-test-wake-wait.patch
-# 0006-futex2-test-timeout.patch
-# 0007-futex2-test-wouldblock.patch
-# 0008-futex2-test-waitv.patch
-# 0009-futex2-test-requeue.patch
-# 0010-futex2-benchmark.patch
- 0011-futex2-enable-waitpid-for-futex2.patch
+ futex2-tkg.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -40,22 +30,10 @@ validpgpkeys=(
'C7E7849466FE2358343588377258734B41C31549' # David Runge <dvzrv@archlinux.org>
)
sha256sums=('SKIP'
- 'fcfb29005032125010bcf18ce2f177af7c84c74cff729de8f0cc3e4a552a59a4'
+ '3b073807b13ac374133485b58a2facb090ffc6ca580505270fc85246dd14b12a'
# -- covolunablu-gaming patches --
'f6701a4b9ed60ad98396606a4c7db26c7197e76d00a28f5299d2567bf6d17d3d'
-# 'cb37801751ea51bc7e784331132f9390b61e477491f103bec3b48f1e751c79b7'
-# 'bbbbc90c25659c16f2697b509a15a3969bf0dd277e81b44718a8149e61b51dbc'
- '695af5865c0048ccc2a458a151607cb609642ad295b9f562440f7cdec7dffae2'
- 'a8183948f375ceb4ac4623531a97aa885b3e4403e50e02c4698af5aaade05bb8'
- '2a8c8ed6607150a4ab25db3320b91d15d9693c55b7b01fbbb00d4b323b8a1230'
- '91e604ce4fb59df365ad88219269a57bbf09811b0a7ff4833b3fab072ad5b038'
-# '001157deded265983c100bd215bad4493de8a4e1e9ede95587018913187ab71a'
-# '141ae54946f64596fb9bf4ecf1c885acdaf730aef9a4b2fe9699b026f8827685'
-# '40d90f134900c9515a274dae011d4adebdc7f4cafe0a6a833cce55e6a86ee84a'
-# '5ca3ad330fb7d792fca01a014280c70231d99de9149044569fc1f96ca0f8aaee'
-# '937a01c0c02c05c0a33890ef5a6e3b9f6c7d61b3283d2b79145ae05bc1ae6c88'
-# 'c97748f88974c6ffe2e0903ffca524104b22939cddf5cc92c2b064ea5ceab880'
- 'c71f09b597b5f97895421dba2e7d76e4fb4338c6b18ed51f5a09e0775f749b4f'
+ '32cf6c57412a8ac7272c83a7f44da56f1c6ef9c3ad389d7f37cdc4f8ffd6ae6e'
)
export KBUILD_BUILD_HOST=covolunablu
@@ -82,7 +60,7 @@ prepare() {
echo "Setting config..."
cp ../config .config
make olddefconfig
-
+
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
@@ -93,7 +71,7 @@ build() {
}
_package() {
- pkgdesc="The $pkgdesc kernel and modules; it includes BFQ as default scheduler and the steam fsync_v2 patches for proton"
+ pkgdesc="The $pkgdesc kernel and modules; it includes BFQ as default scheduler and Valve futex2 patches."
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
@@ -120,7 +98,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ pkgdesc="Headers and scripts for building modules for the linux-covolunablu-gaming kernel"
depends=(pahole)
cd $_srcname