aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2022-04-16 18:38:40 +0200
committerMatteo De Carlo2022-04-16 18:38:40 +0200
commit8a53b6fe08d1f8e035330dc45643c9518d462ef8 (patch)
tree7562ab1138d4db6ab5c4a012f0f59ba0bdae0a53 /PKGBUILD
parentcead3cc2ed690c17fa342f588e5ee1aaf5c11ae3 (diff)
downloadaur-8a53b6fe08d1f8e035330dc45643c9518d462ef8.tar.gz
update to 5.17.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a912b7802e9b..d0d2ffa7a278 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Matteo De Carlo <matteo.dek at gmail dot com>
# Maintainer: Roberto Benfatto <robenfatto at covolunablu dot org>
-# Contributor: Jan Alexander Steffens (heftig) <jan dot steffens at gmail dot com>
+# Original package from: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-covolunablu-gaming
-pkgver=5.17.1.arch1
+pkgver=5.17.3.arch1
pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -11,8 +11,8 @@ url="https://github.com/archlinux/linux/commits/$_srctag"
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
options=('!strip')
@@ -29,7 +29,7 @@ validpgpkeys=(
'C7E7849466FE2358343588377258734B41C31549' # David Runge <dvzrv@archlinux.org>
)
sha256sums=('SKIP'
- 'c05ff4ca7a69b94ace73d1019c398f3fd93dfa0ebcc9b2396b56aaa191fc72e0'
+ 'c0ef360e34fd21c23509224abae894b0d6d37256cccf82575062a05986ee5dba'
# -- covolunablu-gaming patches --
'f6701a4b9ed60ad98396606a4c7db26c7197e76d00a28f5299d2567bf6d17d3d')
@@ -71,7 +71,7 @@ build() {
_package() {
pkgdesc="The $pkgdesc kernel and modules; it includes BFQ as default scheduler (quite vanilla now, will add patches when needed)."
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
@@ -89,7 +89,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}