aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2016-02-04 15:44:56 +0100
committerMatteo De Carlo2016-02-04 15:44:56 +0100
commit99d9bc7aebbdf16735171583fad1ce469ea4ac27 (patch)
tree2f19226475d07b708269f4a03a41d587f75d657a /PKGBUILD
parent33c90908eb78fa07bac5e5821595d832ac74145a (diff)
downloadaur-99d9bc7aebbdf16735171583fad1ce469ea4ac27.tar.gz
Updated to 4.4
- updated kernel to 4.4.1 (based on 4.4.1-2 archlinux package) - update BFQ to v7r11 - update xpad to newer version upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 50 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25406cf7ea8d..6cd0e09c1287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,55 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-covolunablu-gaming # Build kernel with a different name
-_srcname=linux-4.3
-pkgver=4.3.3
+_srcname=linux-4.4
+pkgver=4.4.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
-conflicts=('steamos-xpad-dkms') # because is already included in the kernel itself, no need to use dkms
+
+# Because is already included in the kernel itself, no need to use dkms.
+#
+# However this line can be removed. Having steamos-xpad-dkms is not really giving
+# problems, is just useless since is already included.
+conflicts=('steamos-xpad-dkms')
+
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- "0001-disabling-primary-plane-in-the-noatomic-case.patch"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r8-4.3.patch"
- "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0002-block-introduce-the-BFQ-v7r8-I-O-sched-for-4.3.patch"
- "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.3.0.patch"
- "https://raw.githubusercontent.com/ValveSoftware/steamos_kernel/96053cb77390d18cc76cebead210481ea173bee5/drivers/input/joystick/xpad.c")
-
-sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
+ '0001-sdhci-revert.patch'
+ 'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
+ '0001-4.4-revert-btrfs.patch'
+ '0001-4.4-revert-xfs.patch'
+ "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.4.0-v7r11/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r11-4.4.0.patch"
+ "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.4.0-v7r11/0002-block-introduce-the-BFQ-v7r11-I-O-sched-for-4.4.0.patch"
+ "http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.4.0-v7r11/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r11-for.patch"
+ "https://raw.githubusercontent.com/ValveSoftware/steamos_kernel/8e9ecc9caee1ae1d18c2cc4572729ef355091b6e/drivers/input/joystick/xpad.c")
+
+sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
'SKIP'
- '95cd81fcbb87953f672150d60950548edc04a88474c42de713b91811557fefa5'
+ 'c0218043e61da3921cd14579ae4a8774a6fdad91667a9fdb851d0a35f62edb48'
'SKIP'
- 'abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d'
- '5e3805dfc92c0a48436a565e87bd2452cacc60c92cd0a55bfdee8ea73337f8af'
- '576b7785b58a41b53dcf03d04a652e50520e3f3fe28576e9101a28cc77784f25'
+ '931914bdf174b32cb09be2cc07890f1219f78705856b909656c11ea4db013a60'
+ '14a909cd5b6139d0290319ff4130d9ea9067645c27e922fdcbfdf02f1af716b6'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490'
- '91b7cb42b8337b768e5329da205a6b61211628ec99b1e308e0e9d5283b2c86eb'
- '77430c7154670dd288b6d5bd45896222bf955f02029ee5d0cfe97cc5d9bc1a9d'
+ '5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
+ 'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
+ '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
+ 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad'
+ 'd1cf14cc696b0f716454fe8eb9746383700889d5d22ad829611f0433cc77b4ce'
+ 'b17c3fb18c5b8c20a45a38198f293679ca6aef08d16f12cd816a5cfafac4b2c4'
+ '69a21bc286a628128cfc4723558829cb6ff6c2d7c4dfd4468457898674187b25'
'e9265e1d2d72a0da6600894707438f7c324eb98148e9fa34fcfd566fd8eaf9b7')
-
-
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -56,19 +66,28 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
+ # fixes #47778 sdhci broken on some boards
+ # https://bugzilla.kernel.org/show_bug.cgi?id=106541
+ patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
+
+ # fixes #47805 kernel panics on platform modules
+ # https://bugzilla.kernel.org/show_bug.cgi?id=110751
+ patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
+
+ # #47757 fix broken suspend from btrfs and xfs
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix #469668
- # hangs on older intel hardware
- patch -Np1 -i "${srcdir}/0001-disabling-primary-plane-in-the-noatomic-case.patch"
-
# add BFQ
- patch -p1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r8-4.3.patch"
- patch -p1 -i "${srcdir}/0002-block-introduce-the-BFQ-v7r8-I-O-sched-for-4.3.patch"
- patch -p1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r8-for-4.3.0.patch"
+ patch -p1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r11-4.4.0.patch"
+ patch -p1 -i "${srcdir}/0002-block-introduce-the-BFQ-v7r11-I-O-sched-for-4.4.0.patch"
+ patch -p1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r11-for.patch"
# use steamos version of xpad
cp "${srcdir}/xpad.c" ./drivers/input/joystick/xpad.c
@@ -286,6 +305,11 @@ _package-headers() {
# remove unneeded architectures
rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
+
+ # remove a files already in linux-docs package
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-01"
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.recursion-issue-02"
+ rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild/Kconfig.select-break"
}
_package-docs() {