aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2018-05-08 17:30:33 +0200
committerMatteo De Carlo2018-05-08 17:30:33 +0200
commita227cb344e51bb158085a2472e6bdc57b547d5f1 (patch)
tree3a63f45249104ea9c82dfe20f02dd1164045a876 /PKGBUILD
parent965006cdf1734e03c6949afe847616ee935c3c1d (diff)
downloadaur-a227cb344e51bb158085a2472e6bdc57b547d5f1.tar.gz
Update to 4.16.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f40beeb33c38..fd871fdb1095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Thomas Baechler <thomas at archlinux dot org>
pkgbase=linux-covolunablu-gaming
-_srcname=linux-4.15
-pkgver=4.15.15
+_srcname=linux-4.16
+pkgver=4.16.7
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -28,6 +28,7 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0003-Partially-revert-swiotlb-remove-various-exports.patch
bfq-default.patch
bfq-lock-division-zero.patch
https://raw.githubusercontent.com/ValveSoftware/steamos_kernel/c4948d923637a956853df0e85a6d530e483bdffa/drivers/input/joystick/xpad.c
@@ -36,17 +37,18 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
+sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- 'd8e7f93e24db5517a1be2030a765431120e07f7cd55e510d0de562c70e45bc00'
+ 'f5ef83461054024814846eb816c76eba1b903f7e3e38c3417027b33070b60d91'
'SKIP'
- 'e97d3a519c0bb0af86285c7a70a5eb313793b1ca7e66d7a5246286f3b4110527'
+ '242fb87ff64e1a4e0b608239cadd46f49eb08ab751481a1fe7ac9e8f084b0959'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
# -- patches
- '19b17156ea5aec86e4eb87fc855789375a5184faf564b4ac2cd0f279de7b3bf9'
- 'f49e23e2a00357f8a5f6cc5caadd56a4df2b0a3e2b53d76a514ca508f25a62a7'
+ '7fb607fe384dd814e9e45d7fc28f7b5b23a51d80784c54bf9209486ad428be14'
+ 'ceaa19e0af3842c62eb666a4ac5c79d89b3e6d00593442f18d6508ca6d74bbaa'
+ '5b397cf9eccdad0c1f2865842c29ba6f4e32ad7dbe4e0c6ef6ca6f07d2963cea'
'a20f72660076bc5f73404800da9bc52ceb592bdfbdab19438d66da8c01edc4f4'
'2a40a1906c5bef180035c8af21c38c1f364a81f38507b684058803b3fa9fcfd6'
'851b79826c1695acf93faffb17bcb420c11d12cfa96ac6b5082e4306c2d8fb55'
@@ -70,6 +72,9 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ # NVIDIA driver compat
+ patch -Np1 -i ../0003-Partially-revert-swiotlb-remove-various-exports.patch
+
# use bfq as default scheduler
patch -p1 -i ../bfq-default.patch
@@ -193,9 +198,6 @@ _package-headers() {
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/9912
- install -Dt "${_builddir}/drivers/media/dvb-core" -m644 drivers/media/dvb-core/*.h
-
# http://bugs.archlinux.org/task/13146
install -Dt "${_builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h