summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-05-29 15:55:59 +0300
committerYurii Kolesnykov2019-05-29 15:55:59 +0300
commit8b713818392f2c7190b3450695debfe8ab1e802f (patch)
treec0b004ddea5ba7465d2c6cb4c02b653b5054b36a /PKGBUILD
parentcda018d9274e6e5ee79ec4b5031078774b21de96 (diff)
downloadaur-8b713818392f2c7190b3450695debfe8ab1e802f.tar.gz
5.3.840020.cd6c84d8f0cd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca5e52e6de20..ed6f9895a02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,9 @@
pkgbase=linux-drm-fixes-git
pkgdesc='DRM kernel graphics driver development tree'
_srcname=${pkgbase}
-_kernel_rel=5.2
_branch=drm-fixes
_kernelname=${pkgbase#linux}
-pkgver=5.2.812644.1c163f4c7b3f
+pkgver=5.3.840020.cd6c84d8f0cd
pkgrel=1
arch=('x86_64')
url='https://cgit.freedesktop.org/drm/drm'
@@ -26,14 +25,17 @@ source=("${pkgbase}::git://anongit.freedesktop.org/drm/drm#branch=${_branch}"
linux.preset # standard config files for mkinitcpio ramdisk
)
sha256sums=('SKIP'
- 'f1c9249a7773792a6ae0a19e8ab4354e3b23841933484d25df1c79ec05c29d51'
+ 'd868e199024ad105e0527a8b7c453089f5fb3a9db6b425c43f3f4cdf8c90987e'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
pkgver() {
cd "${_srcname}"
+ local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
+ local patch="$(grep \^PATCHLEVEL Makefile|cut -d"=" -f2|cut -d" " -f2)"
+ patch=$(( $patch + 1 ))
- echo ${_kernel_rel}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ echo $version.$patch.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
_kernelname=${pkgbase#linux}
@@ -66,7 +68,9 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules htmldocs
+#mainline: disabled for 5.1-rc5
+#make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -217,17 +221,19 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ #mainline: disabled for 5.1-rc5
+
+ #msg2 "Removing doctrees..."
+ #rm -r "$builddir/Documentation/output/.doctrees"
+
+ #msg2 "Moving HTML docs..."
+ #local src dst
+ #while read -rd '' src; do
+ #dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ #mkdir -p "${dst%/*}"
+ #mv "$src" "$dst"
+ #rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ #done < <(find "$builddir/Documentation/output" -type f -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"