summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-02-04 21:33:17 +0100
committerYurii Kolesnykov2019-02-04 21:33:17 +0100
commitbd615b5954db90ca695d5be6471e44784e521559 (patch)
tree59ecbbe80ea5f81a6a5571cf2be6c1e105336064 /PKGBUILD
parent29532a870202ce3fa9dcbbd85d514d5876d7c625 (diff)
downloadaur-bd615b5954db90ca695d5be6471e44784e521559.tar.gz
5.1.811648.2072ce03637f-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cb06bbe5435..b2b3ede9ab69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _kernel_rel=5.1
_branch=drm-fixes
_kernelname=${pkgbase#linux}
pkgver=5.1.811648.2072ce03637f
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://cgit.freedesktop.org/drm/drm'
license=(GPL2)
@@ -78,15 +78,17 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
@@ -149,7 +151,6 @@ _package-headers() {
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
- install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/macros.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h