summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Eriksson2018-05-08 16:10:24 +0200
committerMikael Eriksson2018-05-08 16:10:24 +0200
commit0eb1ae0ec6b4f19876b491784fd2e7401e8c4a68 (patch)
treef5f2ef863d31be0db84f40b330d64ef7ba975f9b /PKGBUILD
parent51d544f5232d07b6592aeeff2740f8b2e551c31b (diff)
downloadaur-0eb1ae0ec6b4f19876b491784fd2e7401e8c4a68.tar.gz
Fixed LOCALVERSION/EXTRAVERSION
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37e6931181e1..7c1f37985a50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,21 +38,27 @@ _kernelname=${pkgbase#linux}
prepare() {
cd "${srcdir}/linux"
- cp -Tf ../config .config
-
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n
END
+ # mainline: Fix LOCALVERSION
+ touch .scmversion
+
+ # mainline: we have -rcX in EXTRAVERSION, don't touch it
# set extraversion to pkgrel and empty localversion
- sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
- -e "/^EXTRAVERSION =/aLOCALVERSION =" \
- -i Makefile
+ #sed -e "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" \
+ # -e "/^EXTRAVERSION =/aLOCALVERSION =" \
+ # -i Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
+ # mainline: Disabled here, causes make config to run before olddefconfig
+ # get kernel version
+ #make prepare
+
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
@@ -62,6 +68,7 @@ END
make olddefconfig
# ... or manually edit .config
+ # mainline: moved here from before make config
# get kernel version
make prepare