summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Eriksson2018-02-12 11:15:04 +0100
committerMikael Eriksson2018-02-12 11:15:04 +0100
commit135af0f1c213ba7f41808e5088aa3eff88f2796c (patch)
tree47a24838d3b25e2faf5f546f09c19bcd04c4318f /PKGBUILD
parent3e9b76854b69fbd887768b6ba56df45940d544bd (diff)
downloadaur-135af0f1c213ba7f41808e5088aa3eff88f2796c.tar.gz
Merge with core/linux 4.15.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 28 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83bb3afbebd9..74c6d9cc90be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,36 +17,42 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf' 'git')
options=('!strip')
source=(
"git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=$_tag"
- 'config' # the main kernel config file
- '60-linux.hook' # pacman hook for depmod
- '90-linux.hook' # pacman hook for initramfs regeneration
- 'linux.preset' # standard config files for mkinitcpio ramdisk
+ config # the main kernel config file
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- )
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+)
+sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
+ 'SKIP'
+ '812499c5d0cc5183606dc9388084df162ca2eb5fa374d8f8b00136fd82825847'
+ 'SKIP'
+ '699ad86e5c6076fc5c544d72191efb7eb302f68169dad8495add0f1d156203ab'
+ 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
+ '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
+ 'b20e25656c9423591afd0325fe26320f50bc3421ff204acbfe5dd88ffb3866fe'
+ '68575230693b374eb68e6100e719c71a196db57fe0ac79ddae02fe72b404e09e'
+ 'b21406c060cf601f879528cfa1b83f524c44d8ecd99689c331a7c6326653d0be')
_kernelname=${pkgbase#linux}
-
-md5sums=('SKIP'
- 'e5ba7cacef24391d44d207c091bcbcfd'
- 'ce6c81ad1ad1f8b333fd6077d47abdaf'
- '90cd68710e3064d9b65f5549570f7821'
- 'a329f9581060d555dc7358483de9760a')
+: ${_kernelname:=-ARCH}
prepare() {
cd "${srcdir}/linux"
cp -Tf ../config .config
- if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
- sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
- fi
+ cat ../config - >.config <<END
+CONFIG_LOCALVERSION="${_kernelname}"
+CONFIG_LOCALVERSION_AUTO=n
+END
# set extraversion to pkgrel
- #sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
+ sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -93,7 +99,7 @@ _package() {
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules
- local _extramodules="extramodules-${_basekernel}${_kernelname:--ARCH}"
+ local _extramodules="extramodules-${_basekernel}${_kernelname}"
ln -s "../${_extramodules}" "${pkgdir}/usr/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from hook
@@ -182,6 +188,9 @@ _package-headers() {
# remove files already in linux-docs package
rm -r "${_builddir}/Documentation"
+ # remove now broken symlinks
+ find -L "${_builddir}" -type l -printf 'Removing %P\n' -delete
+
# Fix permissions
chmod -R u=rwX,go=rX "${_builddir}"