summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-02-04 22:30:19 +0100
committerYurii Kolesnykov2019-02-04 22:30:19 +0100
commit49cb7db1bd392c5d122034999ba4ab0d0a77a561 (patch)
tree3d155464aff1ad6aade381d4a971c45da487c49f /PKGBUILD
parent9e43aec57e7dae1b715ac5fff37ebb8a3c54899d (diff)
downloadaur-49cb7db1bd392c5d122034999ba4ab0d0a77a561.tar.gz
5.1.811101.2cc3b81dfa7f-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d219e92eaaf8..92bc7cb51a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _kernel_rel=5.1
_branch=drm-next
_kernelname=${pkgbase#linux}
pkgver=5.1.811101.2cc3b81dfa7f
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://cgit.freedesktop.org/drm/drm'
license=(GPL2)
@@ -78,15 +78,17 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
@@ -149,7 +151,6 @@ _package-headers() {
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
- install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/macros.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h