summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2022-10-09 00:27:32 +0300
committerYurii Kolesnykov2022-10-09 00:27:32 +0300
commitd8ac95cb54f32550c16861ccbe093022388bb90f (patch)
tree0d76bef578ce0584deac2fdc076dd4fac90ad0a0 /PKGBUILD
parent96fd0570be85dff2f92d9514236a1eb6a2cf1812 (diff)
downloadaur-d8ac95cb54f32550c16861ccbe093022388bb90f.tar.gz
sync with testing/linux
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88bef1522978..45c4708c8e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# based on testing/linux: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-drm-tip-git
+pkgver=6.0.r1125124.74e2443e7681
+pkgrel=1
pkgdesc='Linux kernel with bleeding-edge GPU drivers'
-pkgver=5.14.r1029802.5e0ea887acd4
_product="${pkgbase%-git}"
_branch="${_product#linux-}"
-pkgrel=1
-arch=(x86_64)
url=https://cgit.freedesktop.org/drm-tip
+arch=(x86_64)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
options=('!strip')
@@ -22,10 +22,10 @@ source=(
config # the main kernel config file
)
sha256sums=('SKIP'
- '6030ad40747f2055165a6a9081122034ed45283b51533c9018eda6ebec200b84')
+ '85f7327e262056043514a24eb6c8d46e3ac6a10a6caff09d664dec8827829144')
pkgver() {
- cd "${_srcname}"
+ cd $_srcname
local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
local patch="$(grep \^PATCHLEVEL Makefile|cut -d"=" -f2|cut -d" " -f2)"
@@ -56,6 +56,7 @@ prepare() {
echo "Setting config..."
cp ../config .config
make olddefconfig
+ diff -u ../config .config || :
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -63,16 +64,15 @@ prepare() {
build() {
cd $_srcname
- make all
- make htmldocs
+ make htmldocs all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE KSMBD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
cd $_srcname
@@ -88,7 +88,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -108,11 +109,11 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include