summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Schoenick2019-10-07 14:29:38 -0700
committerJohn Schoenick2019-10-07 14:32:41 -0700
commited02638ae8ca5e752022c9e5c32e6a99f43c7196 (patch)
tree2c3cc3392984324ad6309afc8d5087c8638fbbec /PKGBUILD
parent5ddba3450249178f465e04a4ec64a0cd7a3728a3 (diff)
parentd5cf22e71d9c50ac528062e4c8c5d5a7209223b7 (diff)
downloadaur-ed02638ae8ca5e752022c9e5c32e6a99f43c7196.tar.gz
Merge branch 'upstream' for 5.3.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f63dd6b138e0..39c1f6008a20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-fsync # Build kernel with a different name
-_srcver=5.2.14-arch1
+_srcver=5.3.5-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -23,7 +23,6 @@ source=(
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
futex-wait-multiple-5.2.1.patch # futex-wait-multiple patchset w/opcode 31 for proton-4.11+ testing (aka fsync)
- futex-Consolidate-duplicated-timer-setup-code.patch # 5.3 cleanup patch required for patchset
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -31,12 +30,11 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'e0d0f140128a8574217701e61e874a0a108f3b8cd0f6e35d8b16afe897999f8e'
+ '7d09d1d79a4ecb82502b4483cf989ede3f643e05613de45e12563dfe85d80423'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- 'b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942'
- '6aebfbe06e19207b80d06f382b5e0625958ff2db5719b98844d6de620c195be4')
+ 'b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -73,9 +71,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules, including the futex-wait-multiple patchset for testing with Proton fsync"
- [[ $pkgbase = linux ]] && groups=(base)
- depends=(coreutils linux-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -90,6 +88,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
@@ -146,9 +147,6 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- # ???
- mkdir "$builddir/.tmp_versions"
-
msg2 "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include