summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2019-08-07 20:07:24 +0100
committerLeonidas Spyropoulos2019-08-07 20:07:24 +0100
commitf2f5f7ef193d5bb6ef2435eb3c4d3c62da7bd71e (patch)
tree0aa6dc2dcee074fb11c555258270a7e40fa14803 /PKGBUILD
parent93eed2db6ef96783cb4978cff7c6acff97e14e88 (diff)
downloadaur-f2f5f7ef193d5bb6ef2435eb3c4d3c62da7bd71e.tar.gz
upgpkg: linux-gc 5.2.7-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 038e5e3c7b1f..e964e5f5b9be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,9 +23,9 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-gc
-_srcver=5.2.5-arch1
+_srcver=5.2.7-arch1
pkgver=${_srcver%-*}
-pkgrel=2
+pkgrel=1
_bmqversion=098
arch=(x86_64)
url="https://cchalpha.blogspot.co.uk/"
@@ -38,7 +38,6 @@ options=('!strip')
_srcname=linux-$_srcver
_bmq_patch="v5.2_bmq${_bmqversion}.patch"
_gcc_more_v='20190714'
-_ukms_patch='uksm-5.2.patch'
source=(
"$_srcname.tar.gz::https://git.archlinux.org/linux.git/snapshot/linux-$_srcver.tar.gz"
config # the main kernel config file
@@ -47,21 +46,19 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
"0001_${_bmq_patch}::https://gitlab.com/alfredchen/bmq/raw/master/5.2/${_bmq_patch}"
"0002_enable_additional_cpu_optimizations-${_gcc_more_v}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gcc_more_v}.tar.gz"
- "0003_${_ukms_patch}::https://raw.githubusercontent.com/Szpadel/uksm/patch-2/v5.x/${_ukms_patch}"
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
-sha256sums=('22674945a57daed9f848cb0abf6a75f1aa65e8441556b583bdd7515288e81783'
- '4423813200fefc9e8a5b9956692d763b74824030312983973e3ae5c027a971e2'
+sha256sums=('3a7c185fc8557c0da41316f0165447aa1c9018c2db81eac36c19f68ff464dbff'
+ 'b22d748dd419708cda26970f97bd302d84100b5df0147cbe29d29749d57d2637'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'628efd7ea8d6eb7a015e8790411e2353aa9cd6548099aa5c229a3b1cd25f1794'
- '2466fb4aecc66d1b258b4cbdb2f215b5099f266d8c4386bb62ad1a0acd0caf5b'
- '5febbab9437b1b97605fbfd170660e86d12593dac9033e8a32d112360eec1acc')
+ '2466fb4aecc66d1b258b4cbdb2f215b5099f266d8c4386bb62ad1a0acd0caf5b')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-gc}
@@ -123,7 +120,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the PDS-mq CPU scheduler and UKSM patchset"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the PDS-mq CPU scheduler"
depends=(coreutils linux-firmware kmod mkinitcpio)
optdepends=('crda: to set the correct wireless channels of your country')
provides=("linux-gc=${pkgver}")
@@ -179,7 +176,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel and UKSM patchset"
+ pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
depends=('linux-gc')
provides=("linux-gc-headers=${pkgver}" "linux-headers=${pkgver}")