aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBoohbah2016-05-05 21:28:33 +0000
committerBoohbah2016-05-05 21:28:33 +0000
commit2069f2482ad808cd64b330fbfade6769f889548f (patch)
treefb1a3522a6f098e391d6bca2246e39d7eda2dc4e /PKGBUILD
parent3e863548ff1b4ee5a6a47c22bd4eefbbca7cf5d1 (diff)
downloadaur-2069f2482ad808cd64b330fbfade6769f889548f.tar.gz
Add objtool and CONFIG_STACK_VALIDATION
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 608f675a2581..c6c6f0dc1aa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Jonathan Chan <jyc@fastmail.fm>
+# Contributor: misc <tastky@gmail.com>
pkgbase=linux-git
_srcname=linux
@@ -232,6 +233,10 @@ _package-headers() {
# Fix file conflict with -doc package
rm "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild"/Kconfig.*-*
+ # Add objtool for CONFIG_STACK_VALIDATION
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
+ cp -a tools/objtool "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;