aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Cohen2023-09-19 23:51:52 -0500
committerDavid Cohen2023-09-19 23:51:52 -0500
commit552d8947084e4d7847eb6ff2276be4defcdaa5b6 (patch)
treea2bccb07368adf254d522fb9850da08a29efa717 /PKGBUILD
parentca4f07f0d147c6f5ed214797e564070886e0d15e (diff)
downloadaur-552d8947084e4d7847eb6ff2276be4defcdaa5b6.tar.gz
fix build problem starting from kernel v6.6
'source' link may not be present. Update 'rm' to 'rm -f' to avoid fail in such case. Signed-off-by: David Cohen <dacohen@pm.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e5edb7700b8..6efa48295633 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -187,7 +187,7 @@ _package() {
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
- rm "$modulesdir"/{source,build}
+ rm -f "$modulesdir"/{source,build}
# install config files
install -Dm644 $srcdir/config.user "${pkgdir}${_userconfig}"