aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBoohbah2015-12-14 02:44:54 +0000
committerBoohbah2015-12-14 02:44:54 +0000
commit72f710a79ed8b3f7ea4277676ddd2a6a74e88448 (patch)
tree64ffd31f7e86a72664764b12b0f74071b2fc48ea /PKGBUILD
parent78a56abcd8758cc761379a3a29180878dd20b424 (diff)
downloadaur-72f710a79ed8b3f7ea4277676ddd2a6a74e88448.tar.gz
4.4-rc5 and fix file conflict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fb23d9a70f9..8a594bdde32b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Boohbah <boohbah at gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Jonathan Chan <jyc@fastmail.fm>
pkgbase=linux-git
_srcname=linux
-pkgver=4.4rc3.r0.g31ade3b
+pkgver=4.4rc5.r0.g9f9499a
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -18,7 +19,7 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
"${pkgbase}.preset")
sha256sums=('SKIP'
'596958c9c4b632fdf5e0cdc677859dccac4304ad07a217c9bcb0e4fa58dbea16'
- '99860be65a0011748d12d970bbb89da3911b942649531ce77e4b1f787107c728'
+ '0e2f0fcceb5a8550e608d7b6a4b2fd1196a83868bd38f5896a4f73cceb249334'
'95fcfdfcb9d540d1a1428ce61e493ddf2c2a8ec96c8573deeadbb4ee407508c7')
_kernelname=${pkgbase#linux}
@@ -228,6 +229,9 @@ _package-headers() {
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
done
+ # Fix file conflict with -doc package
+ rm "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/kbuild"/Kconfig.*-*
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;