aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Cohen2023-05-11 22:37:17 -0500
committerDavid Cohen2023-05-11 22:42:21 -0500
commit7a743c2112f27a0a1d38d06ba4d9ea47b3df0808 (patch)
tree9211b1cd280b11917436f7e09db2798ed1fd2093 /PKGBUILD
parent6b2c889d09c6068fed735f6f6858a5e9715abefd (diff)
downloadaur-7a743c2112f27a0a1d38d06ba4d9ea47b3df0808.tar.gz
make linux-git package customization more user-friendly
This patch adds a README file with proper instructions, implements support to customizations in case no previous verions of linux-git is installed, and adds linux-git.install file to print customization instructions post package installation / upgrade. Signed-off-by: David Cohen <dacohen@pm.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7549c3549062..6abf954a8cc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# will be on config.extra file.
pkgbase=linux-git
-pkgver=v6.4.rc1.r12.16a8829130ca
+pkgver=v6.4.rc1.r109.cc3c44c9fda2
pkgrel=1
pkgdesc="Linus Torvalds' Mainline Linux"
url="https://www.kernel.org"
@@ -39,11 +39,11 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('SKIP'
+sha256sums=('SKIP' # linux git source
'6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da' # config
'6e41a729c2f2946d3606ca2c0cb3a058c9700b0f73110eed36dcba91a271e50f' # config.extra
- 'efa6b2082cda719b01d15c5374331784c841a38648da63f95904eb7e1b195e62' # config.user
- 'b5560bc5fb8967aec989b757af8eb4d2f5166a830abb732c8c880fb953dcb52f' # remote
+ 'SKIP' # config.user
+ 'SKIP' # remote
'986e39ee1cb41d342b19f1c5af8016d48afa1e182237dbdcc3f222ae4203ef2d' # patches
)
@@ -65,7 +65,7 @@ pkgver() {
prepare() {
cd $_srcname
- [[ -f "$_userremote" ]] && source "$_userremote"
+ [[ -f "$_userremote" ]] && source "$_userremote" || source "../${_userremote##*/}"
if [[ -n "$REMOTE" && -n "$COMMIT" ]]; then
REMOTE_PREFIX=${source[0]##${_srcname}::git+}
REMOTE_PREFIX=${REMOTE_PREFIX%%torvalds/linux}
@@ -113,6 +113,8 @@ prepare() {
cat ../config ../config.extra > .config
if [[ -f "$_userconfig" ]]; then
cat $_userconfig >> .config
+ else
+ cat ../config.user >> .config
fi
make olddefconfig
diff -u ../config .config || :
@@ -133,6 +135,7 @@ _package() {
'linux-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE KSMBD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
+ install="${pkgbase}.install"
cd $_srcname
local kernver="$(<version)"