summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpyros Stathopoulos2018-11-07 20:30:55 +0000
committerSpyros Stathopoulos2018-11-07 20:30:55 +0000
commit431e78ae6db727fdf688c0c58c675584193bd783 (patch)
tree9564fe9e70bc0230bb4503f1432fb9092acb63b8 /PKGBUILD
parent10fbbdcbd0d7e5c43e919f93beb6804a1d0c649f (diff)
downloadaur-431e78ae6db727fdf688c0c58c675584193bd783.tar.gz
Update to v4.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 53 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e7f4bd01b32..27c0d5e56fcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,44 @@
# Contributor: Alex Forenchich <alex@alexforencich.com>
pkgname=('linux-gpib')
-pkgver=4.1.0
-pkgrel=3
+pkgver=4.2.0
+pkgrel=1
pkgdesc='A support package for GPIB (IEEE 488) hardware.'
arch=('i686' 'x86_64')
url='http://linux-gpib.sourceforge.net/'
license=('GPL')
-depends=('bash' 'linux>=4.15' 'linux<4.16')
+depends=('bash' 'linux>=4.18' 'linux<4.19')
makedepends=('perl' 'python' 'linux-headers' 'bison')
optdepends=('fxload: firmware upload support for NI USB-B, Keithley KUSB-488 and Agilent 82357')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}%20for%203.x.x%20and%202.6.x%20kernels/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'gpib_build.patch'
- 'linux-4.11.patch')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}%20for%203.x.x%20and%202.6.x%20kernels/${pkgver}/${pkgname}-${pkgver}.tar.gz")
install='linux-gpib.install'
backup=('etc/gpib.conf')
-_kernver=4.15
-_extramodules=/usr/lib/modules/extramodules-${_kernver}-ARCH
+_kernver=4.18
+_extramodules=/usr/lib/modules/extramodules-ARCH
-md5sums=('2614bb6dcfde4bf01f6047fdf0ea021f'
- '15f3bfbf7a79ddacdd0d66db5e749648'
- '41083d40c050d78ca93502e23d022a39')
+md5sums=('0241dcc2d16f6d12a7aa2c3a623a55ff')
prepare() {
+
+ msg "Unpacking kernel module source"
cd "${srcdir}/${pkgname}-${pkgver}"
+ tar xvfz "${pkgname}-kernel-${pkgver}.tar.gz"
- msg "Patching sources"
- msg2 "Applying gpib_build.patch"
- patch -Np1 -i "../gpib_build.patch"
- patch -Np1 -i "../linux-4.11.patch"
+ msg "Unpacking userland utils source"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ tar xvfz "${pkgname}-user-${pkgver}.tar.gz"
+ cd "${pkgname}-user-${pkgver}"
echo 'ACTION=="add|change", KERNEL=="gpib[0-9]*", MODE="0660", GROUP="gpib"' >| \
usb/99-gpib-generic.rules
- echo "${pkgver}" >| util/.scm_version.tmp
}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-kernel-${pkgver}"
+
+ msg "Building kernel module"
./bootstrap
@@ -53,18 +53,53 @@ build() {
--disable-python-binding \
--disable-tcl-binding
make
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-user-${pkgver}"
+
+ msg "Building userland utils"
+
+ ./bootstrap
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-guile-binding \
+ --enable-perl-binding \
+ --disable-php-binding \
+ --disable-python-binding \
+ --disable-tcl-binding
+ make
+
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-kernel-${pkgver}"
MAKEFLAGS="-j1" make INSTALL_MOD_PATH="${pkgdir}" DESTDIR="${pkgdir}" install
mkdir -p ${pkgdir}/${_extramodules}
mv ${pkgdir}/lib/modules/$(uname -r)/gpib ${pkgdir}/${_extramodules}/
find ${pkgdir} -depth -type d -empty -exec rmdir {} \;
- install -D -m644 "${srcdir}/${pkgname}-${pkgver}/util/templates/gpib.conf" \
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-user-${pkgver}"
+ MAKEFLAGS="-j1" make INSTALL_MOD_PATH="${pkgdir}" DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}/${pkgname}-${pkgver}/${pkgname}-user-${pkgver}/util/templates/gpib.conf" \
"${pkgdir}/etc/gpib.conf"
+
+ # Clear everything depmod spewed out
+ for f in "modules.alias" "modules.alias.bin" "modules.builtin.bin" \
+ "modules.dep" "modules.dep.bin" "modules.softdep" "modules.symbols" \
+ "modules.symbols.bin" "modules.devname"; do
+ rm "${pkgdir}/lib/modules/$(uname -r)/${f}"
+ done
+ rmdir "${pkgdir}/lib/modules/$(uname -r)"
+ rmdir "${pkgdir}/lib/modules"
+ rmdir "${pkgdir}/lib"
+
}
# vim:ts=4:et:sw=4