summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-12-08 15:16:26 +0200
committerSpyros Stathopoulos2015-12-08 15:16:26 +0200
commit9334978f8d0dfe53cd35872bf61686e4a392846d (patch)
treef2e84d48bc43476042ab4923e91e2aab5b29a56b /PKGBUILD
parenteac5ff3998ce30f968e77a12d2bab17f3056a39e (diff)
downloadaur-9334978f8d0dfe53cd35872bf61686e4a392846d.tar.gz
Update to version 4.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 30 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ecb99f5e5b9..a89d4d3ccd1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,53 @@
# Contributor: Alex Forenchich <alex@alexforencich.com>
pkgname=('linux-gpib')
-pkgver=3.2.21
-pkgrel=8
+pkgver=4.0.2
+pkgrel=1
pkgdesc='A support package for GPIB (IEEE 488) hardware.'
arch=('i686' 'x86_64')
url='http://linux-gpib.sourceforge.net/'
license=('GPL')
-depends=('bash' 'linux>=4.1' 'linux<4.2')
+depends=('bash' 'linux>=4.2' 'linux<4.3')
makedepends=('perl' 'linux-headers' 'bison')
+optdepends=('fxload: firmware upload support for NI USB-B, Keithley KUSB-488 and Agilent 82357')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}%20for%203.x.x%20and%202.6.x%20kernels/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'gpib_build.patch'
- 'linux_api_3.19.patch'
- '99-gpib.rules')
+ 'gpib_build.patch')
install='linux-gpib.install'
+backup='etc/gpib.conf'
-_kernver=4.1
+_kernver=4.2
_extramodules=/usr/lib/modules/extramodules-${_kernver}-ARCH
-md5sums=('91e15d1a30c6e3fd79fc6762e8c1120e'
- '70e4d8fcdf37cb0db61fd515b1d49651'
- '842cc665ec1286276dbd413914d276c4'
- 'e57d143633ca8b66b9905d02b657419c')
+md5sums=('dee2981476bd9c9f467efd3010095935'
+ 'f6efe56c98febd2618c120000d1c31aa')
-build() {
+prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+
msg "Patching sources"
msg2 "Applying gpib_build.patch"
- patch -Np0 -i "${srcdir}/gpib_build.patch"
+ patch -Np1 -i "../gpib_build.patch"
- msg2 "Applying linux 3.19.x API patch"
- patch -Np0 -i "${srcdir}/linux_api_3.19.patch"
+ echo 'ACTION=="add|change", KERNEL=="gpib[0-9]*", MODE="0660", GROUP="gpib"' >| \
+ usb/99-gpib-generic.rules
+ echo "${pkgver}" >| util/.scm_version.tmp
+}
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
./bootstrap
+
./configure \
--prefix=/usr \
- --disable-guile-binding \
- --enable-perl-binding \
- --disable-php-binding \
- --disable-python-binding \
- --disable-tcl-binding
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-guile-binding \
+ --enable-perl-binding \
+ --disable-php-binding \
+ --disable-python-binding \
+ --disable-tcl-binding
make
}
@@ -51,12 +59,9 @@ package() {
mkdir -p ${pkgdir}/${_extramodules}
mv ${pkgdir}/lib/modules/$(uname -r)/gpib ${pkgdir}/${_extramodules}/
- mv ${pkgdir}/usr/sbin/gpib_config ${pkgdir}/usr/bin/gpib_config
- rmdir ${pkgdir}/usr/sbin
- rm -r "${pkgdir}/etc/hotplug"
find ${pkgdir} -depth -type d -empty -exec rmdir {} \;
- install -D -m644 "${srcdir}/99-gpib.rules" "${pkgdir}/etc/udev/rules.d/99-gpib.rules"
-
+ install -D -m644 "${srcdir}/${pkgname}-${pkgver}/util/templates/gpib.conf" \
+ "${pkgdir}/etc/gpib.conf"
}
# vim:ts=4:et:sw=4