summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLevente Polyak2023-09-18 23:51:15 +0200
committerLevente Polyak2023-09-18 23:52:08 +0200
commit9874f360abb55890f87212d885bed0d11db5ea8c (patch)
tree9afc478710c28202682b6676380a4c6caf1accfc /PKGBUILD
parent8f55bce7f8be1038d078b22a42dc564300a21dab (diff)
downloadaur-9874f360abb55890f87212d885bed0d11db5ea8c.tar.gz
update to 6.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 40 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c300b2be0ab1..2de18de8237b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,37 @@
pkgbase=linux-hardened-git
_srcname=${pkgbase/-git/}
-_gitbranch=6.0
-pkgver=6.0.r1123788.gba892e8c4619
+_gitbranch=6.5
+pkgver=6.5.r1202060.g41892b0e8df6
pkgrel=1
pkgdesc='Security-Hardened Linux'
url='https://github.com/anthraxx/linux-hardened'
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
+ bc
+ cpio
+ gettext
git
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
options=('!strip')
source=(
"${_srcname}::git+https://github.com/anthraxx/linux-hardened#branch=${_gitbranch}?signed"
- config # the main kernel config files
+ config # the main kernel config file
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- 'E240B57E2C4630BA768E2F26FC1B547C8D8172C8' # Levente Polyak
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
+ E240B57E2C4630BA768E2F26FC1B547C8D8172C8 # Levente Polyak
)
sha256sums=('SKIP'
- 'd46e113e2d42ecdd73d6ee9e105b94da56854a3efcd7216f334910dd0744b7a0')
+ '7155b93f7864b3e7e36b60ebae1f5cabd3f730c9dc92331cad17a6d8e8f51cf5')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -49,8 +56,6 @@ prepare() {
cd $_srcname
echo "Setting version..."
- rm -f localversion* include/config/kernel.release
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
echo "-r$(git rev-list --count HEAD)" > localversion.30-revision
@@ -75,20 +80,29 @@ prepare() {
build() {
cd $_srcname
- make htmldocs all
+ make all
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
- depends=(coreutils kmod initramfs)
- optdepends=('wireless-regdb: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices'
- 'usbctl: deny_new_usb control')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'usbctl: deny_new_usb control'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
cd $_srcname
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -99,7 +113,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
@@ -168,7 +182,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -207,7 +221,11 @@ _package-docs() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=(linux-hardened-git linux-hardened-headers-git linux-hardened-docs-git)
+pkgname=(
+ linux-hardened-git
+ linux-hardened-headers-git
+ linux-hardened-docs-git
+)
for _p in "${pkgname[@]}"; do
_p=${_p/-git/}
eval "package_$_p-git() {