summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Holz2019-07-11 22:38:36 +0200
committerDaniel Holz2019-07-11 22:38:36 +0200
commit3b708a6e93b6cade71b1629582b827f5ff84a5b5 (patch)
treed36d49a91f10561bbe36e7f368812dd0d0b3c314 /PKGBUILD
parent0804d62bb709beaaa39cdb739ca18011bdd6619b (diff)
downloadaur-3b708a6e93b6cade71b1629582b827f5ff84a5b5.tar.gz
update to 5.2.arch2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2afc0bb48662..4a964b1b02a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Daniel Holz <daniel.holz91@gmail.com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
-# Contributor: AceLan Kao <acelan.kao@canonical.com>
-#pkgbase=linux # Build stock -ARCH kernel
-pkgbase=linux-hynix # Build kernel with a different name
-_srcver=5.1.16-arch1
+pkgbase=linux # Build stock -ARCH kernel
+#pkgbase=linux-custom # Build kernel with a different name
+_srcver=5.2-arch2
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git)
+makedepends=(
+ xmlto kmod inetutils bc libelf git python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick
+)
options=('!strip')
_srcname=archlinux-linux
source=(
@@ -30,7 +31,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '20a1ae46dca5a08f2563edd04978b0222bbafd46f26caccacdbb29b7d935a344'
+ '013defd92c7530724105f323a22ae484cfc4a9053bbdc8eb2260134d873d7d86'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -67,11 +68,11 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with Ubuntu patches for Hynix SSD s2idle from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1801875"
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
[[ $pkgbase = linux ]] && groups=(base)
depends=(coreutils linux-firmware kmod mkinitcpio)
optdepends=('crda: to set the correct wireless channels of your country')
@@ -218,6 +219,18 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"