summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Novosyolov2015-11-03 09:36:08 +0300
committerAnton Novosyolov2015-11-03 09:36:08 +0300
commit5416c3cecd8b7a9fb09bba94da91c5f6dfb22fa1 (patch)
tree8e8c8a63b2b3c08da687cb12446757a1a41bf603 /PKGBUILD
parentfb1392248c51636fe0c1a482f542f609770c9cde (diff)
downloadaur-5416c3cecd8b7a9fb09bba94da91c5f6dfb22fa1.tar.gz
4.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cabd1d8697be..236d880da993 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-ice # Build kernel with a different name
-_srcname=linux-4.2
-pkgver=4.2.5
+_srcname=linux-4.3
+pkgver=4.3
pkgrel=1
-_toipatch=tuxonice-for-linux-4.2.3-2015-10-10.patch
+_toipatch=tuxonice-for-linux-head-4.3.0-rc7-2015-11-01.patch
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -15,8 +15,8 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
+ #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
+ #"https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -26,16 +26,14 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://tuxonice.net/downloads/all/${_toipatch}.bz2"
)
-sha256sums=('cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb'
+sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'SKIP'
- 'b631eb4e8b4911b31111b0838e00f7c4a1b7689abcd2233609831b638493f4fb'
- 'SKIP'
- '1ce5a0e88a207dacf83746f7a40e4fe94362688a5d32ac0805caebf1667c9614'
- 'fc973e8afad386534fa59493b85dbb98b0083567acc42295e7a21d371369f54c'
+ '0f0adf7f4aebc11278352596906182144bd43ffac5207ab6888e03f68ead65fb'
+ '7dd79c051e2caecc35c37f1e2d65836156bdf8d879c102d7b6343d13d3f19233'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'8c270194a0ab5deea628880f42443dff0932d445f1aa6aec6a295924a18b7643'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '6f3640495524c9dbbbc90eee5179da358d7e280659797b1b9d3fb9eab27b8379')
+ '7b82218d17001ab54691552fd87f38482afa4a2923cfdab104381ca0efce8ae0')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -47,7 +45,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
- patch -p1 -i "${srcdir}/patch-${pkgver}"
+ #patch -p1 -i "${srcdir}/patch-${pkgver}"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git