aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryardenac2013-04-11 14:18:53 -0700
committeryar2015-07-03 16:58:23 -0700
commit2a70df31389a9a0a00938e19e2966361f229e194 (patch)
treef80f8279f26d024830b2038a6ce1732214428048 /PKGBUILD
parent7a62af6b9b9892305a4afd0a35999c755e4f2ef8 (diff)
downloadaur-2a70df31389a9a0a00938e19e2966361f229e194.tar.gz
use prepare()
and updating guide
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbd25cc1f4ca..04e65e63fce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ replaces=(kernel26 linux)
backup=(etc/mkinitcpio.d/${pkgname}.preset boot/grub/menu.lst)
install=${pkgname}.install
-build() {
+prepare() {
cd "${srcdir}/${_srcname}"
patch -p1 -i "${srcdir}/patch-${pkgver}"
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
@@ -45,7 +45,9 @@ build() {
sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|g" ./.config
sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
make prepare
-# msg "Stopping build"; return 1
+}
+
+build() {
CFLAGS=${CFLAGS}" -march=corei7 -mtune=corei7 -mcpu=corei7 "
CXXFLAGS=${CXXFLAGS}" -march=corei7 -mtune=corei7 -mcpu=corei7 "
ionice -c 3 nice -n 19 make ${MAKEFLAGS} LOCALVERSION= bzImage modules