summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-24 00:08:00 +0100
committerPiotr Gorski2018-11-24 00:08:00 +0100
commit2d6c0bf444c20d13bab10702571a97aa63a23d95 (patch)
tree17357edefe3dee1a60a862a32dd192655457cf04 /PKGBUILD
parent0df8186773de76262bcf0f24702e6e2cf38cb634 (diff)
downloadaur-2d6c0bf444c20d13bab10702571a97aa63a23d95.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdb1115dbaa4..ef4bbdfa3a81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,13 +30,15 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
+# begin making the pkg unless you're running modprobed-db (AUR) and building
+# this with makepkg as the user who is keeping the database.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
# This PKGBUILD will call it directly to probe all the modules you have logged!
#
-# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed_db
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
# Use the current kernel's .config file
@@ -62,7 +64,7 @@ _lqxpatchrel=27
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=4.18.20_2
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
@@ -170,18 +172,16 @@ prepare() {
fi
### Optionally load needed modules for the make localmodconfig
- # See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
- msg2 "If you have modprobe-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
- fi
- msg2 "Running Steven Rostedt's make localmodconfig now"
- make localmodconfig
- fi
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg2 "Running Steven Rostedt's make localmodconfig now"
+ make localmodconfig
+ fi
+ fi
### Running make nconfig
[[ -z "$_makenconfig" ]] || make nconfig