summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2019-10-04 13:39:40 +0200
committerPiotr Gorski2019-10-04 13:39:40 +0200
commit9da0210742ace45e47e4dd58d2be126a181020c9 (patch)
tree4d13185ad05524562142d0fde55049809bfacab3 /PKGBUILD
parente913eb09a350f115ef0975f7b3ee436ae89e3003 (diff)
downloadaur-9da0210742ace45e47e4dd58d2be126a181020c9.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ac987b6d76a..b64e980e859e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,7 +56,7 @@ _lqxpatchrel=27
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=5.2.18_1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
@@ -191,8 +191,9 @@ build() {
_package() {
pkgdesc="A desktop oriented kernel and modules with Liquorix patches"
- depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -207,6 +208,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install