summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2019-09-03 17:11:24 +0200
committerPiotr Gorski2019-09-03 17:11:24 +0200
commitbe39f6fd50546251472fc5e17350abfb6b64a4ae (patch)
tree9e88ef4735d021c145a0eda91ac3649b5010fbff /PKGBUILD
parent1b02c53a87984ece6f89a26147f173ea5f9e2837 (diff)
downloadaur-be39f6fd50546251472fc5e17350abfb6b64a4ae.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f56fe47cc3d8..eb40aa5fae8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,15 +26,12 @@ _makegconfig=
# See, https://bugs.archlinux.org/task/31187
_NUMAdisable=y
-# Compile ONLY probed modules
-# Build in only the modules that you currently have probed in your system VASTLY
-# reducing the number of modules built and the build time.
-#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# Compile ONLY used modules to VASTLYreduce the number of modules built
+# and the build time.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD will call it directly to probe all the modules you have logged!
+# This PKGBUILD read the database kept if it exists
#
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
@@ -59,7 +56,7 @@ _lqxpatchrel=16
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=5.2.11_1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
@@ -161,13 +158,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- msg2 "If you have modprobed-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
- make localmodconfig
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg2 "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg2 "No modprobed.db data found"
+ exit
fi
fi