summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2019-04-13 16:09:19 +0200
committerPiotr Gorski2019-04-13 16:09:19 +0200
commitc4dd4441678bbb1a93f6fca2d52cecfc3ec16339 (patch)
tree81b1ff106228975dcce8162e3f6e7611de90a2de /PKGBUILD
parent828d83780b67e7f2692d8ca3a4d95db5b0caad4f (diff)
downloadaur-c4dd4441678bbb1a93f6fca2d52cecfc3ec16339.tar.gz
Revert FS#59688 - Install HTML docs
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 2 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 460338838b5a..b7f3c3a8b998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,9 +49,6 @@ _use_current=
### Disable MUQSS
_muqss_disable=
-### Enable htmldocs (increases compile time)
-_htmldocs_enable=
-
### Do not edit below this line unless you know what you're doing
# pkgname=('linux-lqx' 'linux-lqx-headers' 'linux-lqx-docs')
@@ -62,17 +59,13 @@ _lqxpatchrel=6
_lqxpatchver=${_lqxpatchname}-${_major}-${_lqxpatchrel}
pkgbase=linux-lqx
pkgver=5.0.7_1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://liquorix.net/"
license=('GPL2')
options=('!strip')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
-if [ -n "$_htmldocs_enable" ]; then
- makedepends+=('python-sphinx' 'graphviz')
-fi
-
source=("https://cdn.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.sign"
"https://github.com/damentz/${_lqxpatchname}/archive/${_major}-${_lqxpatchrel}.tar.gz"
@@ -201,12 +194,7 @@ prepare() {
build() {
cd ${_srcname}
- local params=(bzImage modules)
- if [ -n "$_htmldocs_enable" ]; then
- params+=(htmldocs)
- fi
-
- make ${params[*]}
+ make bzImage modules
}
_package() {
@@ -363,20 +351,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- if [ -n "$_htmldocs_enable" ]; then
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
- fi
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"