summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2018-02-17 23:33:03 -0500
committerTony Lambiris2018-02-17 23:34:22 -0500
commit37dd51e7485863783c796448b58732a02b22273e (patch)
tree78fa70a1382d01fa6e3f5cd58c9d74b6d0cb2c04 /PKGBUILD
parente6c6cd1fb8947adb76a2c263470020c84f51c503 (diff)
downloadaur-37dd51e7485863783c796448b58732a02b22273e.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b115e6e9a1d..6ac851a8f897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
_srcname=linux-4.15
-pkgver=4.15.3
-pkgrel=2
+pkgver=4.15.4
+pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -26,8 +26,7 @@ source=(
03-apple-poweroff-quirk-workaround.patch
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- 0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
- 0004-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
+ 0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -35,7 +34,7 @@ validpgpkeys=(
)
sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'SKIP'
- '6dd42389603bc6c83d2e6db1d736303e41d26cef479cad926b87711f261c9c35'
+ '5f8344fcc6b15be5f53001bb18df342bf5877563239f03271c236e3a40db89e8'
'SKIP'
'617d1a2b0160fc72098524a51501531556050cab0e466c9dbae5d60a78991bd2'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
@@ -45,10 +44,9 @@ sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'bb8af32880059e681396a250d8e78f600f248da8ad4f0e76d7923badb5ee8b42'
'7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
'09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff'
- '95bda0b206b917ee907375bb0015b8f04f668bfea74706ce614442326a6be442'
- '2a9adeea2d45513ee3ef0af9fb91c254f14500195e801581b55abcf4ff228eb0'
- '990653b33a736b3941f03d8ca49795109f16507afa34b57dbce3c8e2d2fb26ca'
- '13bc8392b26d1ce0182060fba0f37f74dd7cdc6fff2fdea3240fc4e755621277')
+ 'c7951a3dfa6dcfd6f7c56d8d5c7c89cceb0e612ce3e6134d3fe23d1202b69863'
+ 'b1485882a9d26fe49b9fb2530259c2c39e03a3346ff63edcbc746f47ef693676'
+ '54380eafa1dfb42f7860a5eee9f521c14aa5fd2c9f5bfaa6e0537d75800225b7')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -73,11 +71,8 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- # https://bugs.archlinux.org/task/57327
- patch -Np1 -i ../0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
-
# https://bugs.archlinux.org/task/57500
- patch -Np1 -i ../0004-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
+ patch -Np1 -i ../0003-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"