summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2017-11-23 13:31:11 -0500
committerTony Lambiris2017-11-23 13:31:11 -0500
commit49e217a546d3236984fdb0d66d0c272519ce8415 (patch)
tree35771e9132a4ad70f90b1a9eb506fa69347b62a8 /PKGBUILD
parent5c48927e3295b1cf2b473c06fccc7c24cb878ac4 (diff)
downloadaur-49e217a546d3236984fdb0d66d0c272519ce8415.tar.gz
Add patch from -ARCH
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05fd558db056..982d5c928bf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=linux-macbook # Build kernel with a different name
_srcname=linux-4.14
pkgver=4.14.1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -30,6 +30,7 @@ source=(
'RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch'
'intel-pstate-backport.patch'
'0001-platform-x86-hp-wmi-Fix-tablet-mode-detection-for-co.patch'
+ '0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch'
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -49,7 +50,8 @@ sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
'09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff'
'3d9fdbb4bee270efa6eef1d8e40a5ae562a87d5a2edae629e0829cc51714de13'
- '6f1d9b6a119bfab150a0bc1f550609dd9290328df709b67c984f0a6b0abe8afd')
+ '6f1d9b6a119bfab150a0bc1f550609dd9290328df709b67c984f0a6b0abe8afd'
+ '92b8755030d405fa4a9cd31cbe2998fd71584164431e5edc28c2be04fab24d1e')
_kernelname=${pkgbase#linux}
@@ -86,6 +88,9 @@ prepare() {
# https://bugs.archlinux.org/task/56207
patch -Np1 -i ../0001-platform-x86-hp-wmi-Fix-tablet-mode-detection-for-co.patch
+ # https://bugs.archlinux.org/task/56404
+ patch -Np1 -i ../0001-bio-ensure-__bio_clone_fast-copies-bi_partno.patch
+
cp -Tf ../config .config
if [ "${_kernelname}" != "" ]; then