summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2018-11-26 05:32:05 -0500
committerTony Lambiris2018-11-26 05:32:05 -0500
commite66b8a51a37f49502dd91f16c7c552df8d21cf36 (patch)
treefa05132cf0a744ed52476cebbd8fa826924f888f /PKGBUILD
parentcc8fbc51375301dd1fe18f92b70d5bba6a0c8e68 (diff)
downloadaur-e66b8a51a37f49502dd91f16c7c552df8d21cf36.tar.gz
Sync with core/linux
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c0ab52a199d..f1d44d7d2d68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
-_srcver=4.18.16-arch1
+_srcver=4.19.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -29,7 +29,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '0e0d831763f080c65c07e06389007ada9f7d77f8148859ac5a2223263cc966e7'
+ 'e7fa30bb2de12d1a2488423e27c00f26d55668e310e69aaf93673c1afd89dbaf'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -82,13 +82,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"