summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2018-02-16 20:53:12 -0500
committerTony Lambiris2018-02-16 20:53:12 -0500
commite6c6cd1fb8947adb76a2c263470020c84f51c503 (patch)
treea2e96a910686fbc90528b9aa2cfc61d371be943f /PKGBUILD
parent25f4684cd588033e2ff25444221d8ad6ec77277f (diff)
downloadaur-e6c6cd1fb8947adb76a2c263470020c84f51c503.tar.gz
Version bump/sync with core repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD120
1 files changed, 43 insertions, 77 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2483ec55798b..3b115e6e9a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,57 @@
-# Maintainer: Tony Lambiris <tony@critialstack.com>
-
# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# Maintainer: Tony Lambiris <tony@critialstack.com>
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-macbook # Build kernel with a different name
-_srcname=linux-4.14
-pkgver=4.14.9
-pkgrel=1
+_srcname=linux-4.15
+pkgver=4.15.3
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
- 'config' # the main kernel config file
- '60-linux.hook' # pacman hook for depmod
- '90-linux.hook' # pacman hook for initramfs regeneration
- 'linux.preset' # standard config files for mkinitcpio ramdisk
+ https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
+ https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
+ config # the main kernel config file
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
macbook-wakeup.service # service file for suspend/resume events
- apple-gmux.patch # linux-macbook specific patches
- PCI-Work-around-poweroff-suspend-to-RAM-issue-on-Mac.patch
- RFC-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
- RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch
- intel-pstate-backport.patch
+ 01-apple-gmux.patch # linux-macbook specific patches
+ 02-macbook-suspend.patch
+ 03-apple-poweroff-quirk-workaround.patch
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0001-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
- 0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
- 0001-Revert-xfrm-Fix-stack-out-of-bounds-read-in-xfrm_sta.patch
- 0002-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
- 0003-cgroup-fix-css_task_iter-crash-on-CSS_TASK_ITER_PROC.patch
- 0001-ALSA-usb-audio-Fix-the-missing-ctl-name-suffix-at-pa.patch
+ 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
+ 0004-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
+sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'SKIP'
- '5edc955bb67b04c7ed426b1df17a3e322e32ad9fdda9c6abb53ab6eca7faf704'
+ '6dd42389603bc6c83d2e6db1d736303e41d26cef479cad926b87711f261c9c35'
'SKIP'
- '4d12ed868b05720c3d263c8454622c67bdee6969400049d7adac7b00907ad195'
+ '617d1a2b0160fc72098524a51501531556050cab0e466c9dbae5d60a78991bd2'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'c5a714823c3418692bc5c212dd5d094a0e2ae6147d6726822911f1c26e3a1d1b'
- 'e74dbeaa3fd04dbf93ef4498015234bdb65351857e07c03c00cee69fcfc844b4'
- '43bcb45f99da0242ec5b340631d0777f302a5f356ef3ccec8d1d30de5a3a025a'
+ 'bb8af32880059e681396a250d8e78f600f248da8ad4f0e76d7923badb5ee8b42'
'7c99aaeaea7837f83a3ad215cf07277934ccf39720acee7f1c371dc86bdf89fc'
'09189eb269a9fd16898cf90a477df23306236fb897791e8d04e5a75d5007bbff'
- '3d9fdbb4bee270efa6eef1d8e40a5ae562a87d5a2edae629e0829cc51714de13'
- '37b86ca3de148a34258e3176dbf41488d9dbd19e93adbd22a062b3c41332ce85'
- 'c6e7db7dfd6a07e1fd0e20c3a5f0f315f9c2a366fe42214918b756f9a1c9bfa3'
- '1d69940c6bf1731fa1d1da29b32ec4f594fa360118fe7b128c9810285ebf13e2'
- 'ed3266ab03f836f57de0faf8a10ffd7566c909515c2649de99adaab2fac4aa32'
- '64a014f7e1b4588728b3ea9538beee67ec63fb792d890c7be9cc13ddc2121b00'
- '3d4c41086c077fbd515d04f5e59c0c258f700433c5da3365d960b696c2e56efb'
- '95f0d0a94983b0dafd295f660a663f9be5ef2fcb9646098426a5d12b59f50638')
+ '95bda0b206b917ee907375bb0015b8f04f668bfea74706ce614442326a6be442'
+ '2a9adeea2d45513ee3ef0af9fb91c254f14500195e801581b55abcf4ff228eb0'
+ '990653b33a736b3941f03d8ca49795109f16507afa34b57dbce3c8e2d2fb26ca'
+ '13bc8392b26d1ce0182060fba0f37f74dd7cdc6fff2fdea3240fc4e755621277')
_kernelname=${pkgbase#linux}
+: ${_kernelname:=-ARCH}
prepare() {
cd ${_srcname}
@@ -71,58 +59,33 @@ prepare() {
# add upstream patch
patch -p1 -i ../patch-${pkgver}
- # security patches
-
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
# start of macbook specific patches
- msg "patch -p1 -F1 -i ${srcdir}/apple-gmux.patch"
- patch -p1 -F1 -i "${srcdir}/apple-gmux.patch"
-
- # https://patchwork.kernel.org/patch/9821773/
- #msg "patch -p1 -F1 -i ${srcdir}/PCI-Work-around-poweroff-suspend-to-RAM-issue-on-Mac.patch"
- #patch -p1 -F1 -i \
- # "${srcdir}/PCI-Work-around-poweroff-suspend-to-RAM-issue-on-Mac.patch"
-
- # https://patchwork.kernel.org/patch/9140867/
- msg "patch -p1 -F1 -i ${srcdir}/RFC-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch"
- patch -p1 -F1 -i \
- "${srcdir}/RFC-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch"
-
- # https://patchwork.kernel.org/patch/9288825/
- msg "patch -p1 -F1 -i ${srcdir}/RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch"
- patch -p1 -F1 -i \
- "${srcdir}/RFC-v2-PCI-Workaround-to-enable-poweroff-on-Mac-Pro-11.patch"
+ patch -Np1 -i ../01-apple-gmux.patch
+ patch -Np1 -i ../02-macbook-suspend.patch
+ patch -Np1 -i ../03-apple-poweroff-quirk-workaround.patch
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- # https://bugs.archlinux.org/task/56575
- patch -Np1 -i ../0001-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
-
- # https://nvd.nist.gov/vuln/detail/CVE-2017-8824
- patch -Np1 -i ../0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
-
- # https://bugs.archlinux.org/task/56605
- patch -Np1 -i ../0001-Revert-xfrm-Fix-stack-out-of-bounds-read-in-xfrm_sta.patch
- patch -Np1 -i ../0002-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
+ # https://bugs.archlinux.org/task/56711
+ patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- # https://bugs.archlinux.org/task/56846
- patch -Np1 -i ../0003-cgroup-fix-css_task_iter-crash-on-CSS_TASK_ITER_PROC.patch
+ # https://bugs.archlinux.org/task/57327
+ patch -Np1 -i ../0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
- # https://bugs.archlinux.org/task/56830
- patch -Np1 -i ../0001-ALSA-usb-audio-Fix-the-missing-ctl-name-suffix-at-pa.patch
+ # https://bugs.archlinux.org/task/57500
+ patch -Np1 -i ../0004-x86-xen-init-gs-very-early-to-avoid-page-faults-with.patch
- cp -Tf ../config .config
-
- if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
- sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
- fi
+ cat ../config - >.config <<END
+CONFIG_LOCALVERSION="${_kernelname}"
+CONFIG_LOCALVERSION_AUTO=n
+END
# set extraversion to pkgrel
- sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
+ sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -168,7 +131,7 @@ _package() {
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules
- local _extramodules="extramodules-${_basekernel}${_kernelname:--ARCH}"
+ local _extramodules="extramodules-${_basekernel}${_kernelname}"
ln -s "../${_extramodules}" "${pkgdir}/usr/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from hook
@@ -261,6 +224,9 @@ _package-headers() {
# remove files already in linux-docs package
rm -r "${_builddir}/Documentation"
+ # remove now broken symlinks
+ find -L "${_builddir}" -type l -printf 'Removing %P\n' -delete
+
# Fix permissions
chmod -R u=rwX,go=rX "${_builddir}"