summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsayad2021-01-24 23:17:49 +0600
committersayad2021-01-24 23:17:49 +0600
commitf6bceb445a76efc5e52c835101a13c13cc678f93 (patch)
treecf95a5f42655196e3a94bdfe68089be466a0620c /PKGBUILD
parenteafdda8af6a28d20946921e23c1d24ddaf489c0c (diff)
downloadaur-f6bceb445a76efc5e52c835101a13c13cc678f93.tar.gz
Bug fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3059b3e7ac21..631ba58260cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,6 @@ _ispkgbuild="true"
source "$_where"/customization.cfg # load default configuration from file
source "$_where"/prepare
-source "$_where"/bcachefs
_tkg_initscript
@@ -65,6 +64,8 @@ case $_basever in
510)
opt_ver="5.8%2B"
source=("$kernel_site"
+ prepare
+ customization.cfg
"$patch_site"
"https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/master/enable_additional_cpu_optimizations_for_gcc_v10.1%2B_kernel_v5.8%2B.patch"
'config.x86_64' # stock Arch config
@@ -95,6 +96,8 @@ case $_basever in
"https://raw.githubusercontent.com/Frogging-Family/linux-tkg/master/linux-tkg-patches/5.10/0012-misc-additions.patch"
)
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
'f60f800329a7461e5ff542f7f19e24a073f1e49a74f96dfb5d45a899f6a9cad8'
'SKIP'
'fc5fc8944d0926cfc0aaf17be493ebe6549d8709f354191df6078337544cb3cb'
@@ -127,7 +130,7 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
rm -rf $pkgdir # Nuke the entire pkg folder so it'll get regenerated clean on next build
-li
+
ln -s "${_where}/customization.cfg" "${srcdir}" # workaround
ln -s "${_where}/${_srcpath}" "${srcdir}" # workaround