summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfokx2024-05-09 17:30:51 +0800
committerfokx2024-05-09 17:30:51 +0800
commitb5fb95ecc08fa7b138b3fe94aed885e2a41b72f1 (patch)
tree09369c20160577bb8630fdc1f5ac636199da2a96 /PKGBUILD
parent0f797787e7d9d8fe9423a3e7a689ea0770302e6e (diff)
downloadaur-b5fb95ecc08fa7b138b3fe94aed885e2a41b72f1.tar.gz
fix build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caaf0d02bf06..10214750e792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# will be on config.extra file.
pkgbase=linux-mainline-git
-pkgver=v5.18.r2752.fdaf9a5840ac
+pkgver=v6.9.rc7.r56.45db3ab70092
pkgrel=1
pkgdesc="Linus Torvalds' Mainline Linux"
url="https://www.kernel.org"
@@ -22,13 +22,13 @@ backup=(
)
makedepends=(
bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ xmlto
git
)
options=('!strip')
-_srcname=linux-torvalds
+_srcname=linux-mainline
source=(
- "$_srcname::git+https://kernel.googlesource.com/pub/scm/linux/kernel/git/torvalds/linux"
+ "$_srcname::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git"
config # the main kernel config file
config.extra # additional configs
config.user # user custom config
@@ -40,7 +40,7 @@ validpgpkeys=(
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
sha256sums=('SKIP'
- '5088714ec20c9c5b063decbf2210f5b153a908a71678aa156f5f3e81394e9c38'
+ 'c2b00c84c4b543db431e06604d939a62f93107d18369f4d9860dc8062b01ab45'
'6e41a729c2f2946d3606ca2c0cb3a058c9700b0f73110eed36dcba91a271e50f'
'b5ced6ad1f03a5cfe6dccc0b2b31f91420cfe97823e5d15d5b94b7224362daa9'
'b5560bc5fb8967aec989b757af8eb4d2f5166a830abb732c8c880fb953dcb52f'
@@ -83,7 +83,21 @@ prepare() {
fi
echo "Setting version..."
- scripts/setlocalversion --save-scmversion
+# scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+
+ echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
@@ -129,9 +143,9 @@ build() {
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(KSMBD-MODULE VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
cd $_srcname
@@ -150,7 +164,7 @@ _package() {
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
- rm "$modulesdir"/{source,build}
+ rm -f "$modulesdir"/{source,build}
# install config files
install -Dm644 $srcdir/config.user "${pkgdir}${_userconfig}"