summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-03-22 12:07:46 +0100
committerBaptiste Jonglez2016-03-22 12:14:06 +0100
commit5db521c27480e84319b4e571428ce0f7fcd333fa (patch)
tree02772cdb44c8f2b41a9e7621bf570e4a857ba9bf /PKGBUILD
parent5f6b2d1a6d79026731a4a2f5ce9bc2952b93767e (diff)
downloadaur-5db521c27480e84319b4e571428ce0f7fcd333fa.tar.gz
linux-mptcp: Update to v0.91 (based on linux 4.1.20)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c1e46d6853c..12ee9467b9d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
pkgbase=linux-mptcp
_srcname=mptcp
-_mptcpv=0.90
-pkgver=0.90.487573.41341ce
-pkgrel=2
+_mptcpv=0.91
+pkgver=0.91.525000.c6ba013
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.multipath-tcp.org/"
license=('GPL2')
@@ -21,8 +21,8 @@ source=("git://github.com/multipath-tcp/mptcp#branch=mptcp_v${_mptcpv}"
'linux.preset'
'change-default-console-loglevel.patch')
md5sums=('SKIP'
- '9833eaf0d4c476454d3981b62a21506b'
- 'bd42ba55663f7ae8e6aba34e52139ca6'
+ 'c4300a2b9efdb107dddcb11dc9a79bf4'
+ 'ac8ddda9b061b9191f48ce3dfe89508c'
'eb14dcfd80c00852ef81ded6e826826a'
'92562f0a5d8cc0e5972ab58523dbe0a4')
@@ -36,9 +36,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_srcname}"
- # add latest fixes from stable queue, if needed
- # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -91,7 +88,7 @@ build() {
}
_package() {
- pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 3.18.26)"
+ pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 4.1.20)"
[ "${pkgbase}" = "linux" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country'
@@ -133,8 +130,6 @@ _package() {
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
# remove the firmware
rm -rf "${pkgdir}/lib/firmware"
- # gzip -9 all modules to save 100MB of space
- find "${pkgdir}" -name '*.ko' -exec gzip -9 {} \;
# make room for external modules
ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from post_install/upgrade