summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-12-17 20:12:59 +0100
committerBaptiste Jonglez2016-12-17 22:35:06 +0100
commit74068adef1b7f4a8cfc7f6db992806b2eda1fd71 (patch)
tree4d440e3990e1c4dabdfb5fdfd46759be5969d34e /PKGBUILD
parent58dc511c8cb005607d5b2bdf78753ecb51ff4ce8 (diff)
downloadaur-74068adef1b7f4a8cfc7f6db992806b2eda1fd71.tar.gz
linux-mptcp: Catch up with linux in [core] (pacman hook for mkinitcpio, etc)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9d51b9ae37a..4a791589c2f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=linux-mptcp
_srcname=mptcp
pkgver=0.91.2.r3.g7dc057e
-pkgrel=1
+pkgrel=2
epoch=1
arch=('i686' 'x86_64')
url="http://www.multipath-tcp.org/"
@@ -17,14 +17,17 @@ options=('!strip')
source=("git+https://github.com/multipath-tcp/mptcp#commit=7dc057edb502ded02b91ae9a68f1114ddcf4c8ff"
# the main kernel config files
'config' 'config.x86_64'
+ # pacman hook for initramfs regeneration
+ '99-linux.hook'
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch')
-md5sums=('SKIP'
- '4b08d92164ee25f2a680700e426f6cd5'
- '6a74094caead06597a356c864c8872bc'
- 'eb14dcfd80c00852ef81ded6e826826a'
- '92562f0a5d8cc0e5972ab58523dbe0a4')
+sha256sums=('SKIP'
+ '3fb70bb34f132e0849be975592f98371160f53b9c2c457ed4468e88fdba8c0ed'
+ '09c489756410cdd9e014a5504ee7c0508401d445a050c1911b8c0667349e1451'
+ '834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
+ '567bdc00dbecae3e03c4d5306c8156d4a76485925404cf0c30f15f2c3661d32f')
_kernelname=${pkgbase#linux}
@@ -111,21 +114,17 @@ _package() {
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# set correct depmod command for install
- cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
+ sed -e "s|%PKGBASE%|${pkgbase}|g;s|%KERNVER%|${_kernver}|g" \
+ "${startdir}/${install}" > "${startdir}/${install}.pkg"
true && install=${install}.pkg
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
- -i "${startdir}/${install}"
# install mkinitcpio preset file for kernel
- install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
- sed \
- -e "1s|'linux.*'|'${pkgbase}'|" \
- -e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgbase}\"|" \
- -e "s|default_image=.*|default_image=\"/boot/initramfs-${pkgbase}.img\"|" \
- -e "s|fallback_image=.*|fallback_image=\"/boot/initramfs-${pkgbase}-fallback.img\"|" \
- -i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/linux.preset" |
+ install -D -m644 /dev/stdin "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+
+ # install pacman hook for initramfs regeneration
+ sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
+ install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
@@ -145,7 +144,7 @@ _package() {
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# add vmlinux
- install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+ install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
}
_package-headers() {