summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-10-29 16:29:40 +0200
committerBaptiste Jonglez2016-10-29 18:23:25 +0200
commit98b9bdb1083ddf00e02d1b8a54d94c098dd239ca (patch)
tree1bb6631fd3b33ea589034ad80445515fe29741f9 /PKGBUILD
parentda4df1a112c6e7793d5a5738c28889270f09d94d (diff)
downloadaur-98b9bdb1083ddf00e02d1b8a54d94c098dd239ca.tar.gz
linux-mptcp: Update to v0.91.1
Also change the versioning scheme to a more standard one, because the current scheme broke version comparison when switching from 0.91 to 0.91.1. See https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9da8f08182a5..d0418ef3de29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,9 @@
pkgbase=linux-mptcp
_srcname=mptcp
-_mptcpv=0.91
-pkgver=0.91.525553.1939096
+_mptcpv=0.91.1
+pkgver=0.91.1.r0.g214e17c
+epoch=1
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.multipath-tcp.org/"
@@ -30,7 +31,7 @@ _kernelname=${pkgbase#linux}
pkgver() {
cd "${srcdir}/${_srcname}"
- echo ${_mptcpv}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -88,7 +89,7 @@ build() {
}
_package() {
- pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 4.1.26)"
+ pkgdesc="The Linux kernel and modules with Multipath TCP support (based on linux 4.1.34)"
[ "${pkgbase}" = "linux" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country'