summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2019-11-01 15:52:02 +0100
committerPiotr Gorski2019-11-01 15:52:02 +0100
commit4eaa51cd928c0797e7410586aec46a5c526c05b5 (patch)
tree95b396a5344f94dad31f3735afc287597f737adb /PKGBUILD
parentc09560dc209c93b65036b51d65050c09e0cd0d28 (diff)
downloadaur-4eaa51cd928c0797e7410586aec46a5c526c05b5.tar.gz
Changes for new kmod and mkinitcpio hooks
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 4 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de0b4781d755..f50ba55eed96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ _1k_HZ_ticks=
pkgbase=linux-next-git
pkgver=20191031.r0.g49afce6d47fe
_srcname=linux-next
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -63,18 +63,7 @@ _lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_lucjanver
source=("git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git"
"${_lucjanpath}/arch-patches-v2/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
# the main kernel config files
- 'config'
- # pacman hook for depmod
- '60-linux.hook'
- # pacman hook for initramfs regeneration
- '90-linux.hook'
- # pacman hook for remove initramfs
- '99-linux.hook'
- # standard config files for mkinitcpio ramdisk
- 'linux.preset')
-
-_kernelname=${pkgbase#linux}
-: ${_kernelname:=-next}
+ 'config')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -92,7 +81,7 @@ prepare() {
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
+ echo "${pkgbase#linux}" > localversion.20-pkgname
### Patching sources
local src
@@ -197,8 +186,6 @@ _package() {
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
- install=linux.install
cd $_srcname
local kernver="$(<version)"
@@ -208,7 +195,6 @@ _package() {
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
- install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
@@ -219,27 +205,6 @@ _package() {
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Installing hooks..."
- # sed expression for following substitutions
- local subst="
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- "
-
- # hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
-
- # fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-${pkgbase}.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-${pkgbase}.hook"
- sed "$subst" ../99-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/99-${pkgbase}.hook"
-
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -365,8 +330,4 @@ done
sha512sums=('SKIP'
'8aac877c0dfcd6796bc217572c8b8c6473ab6b5b15b7cca0e7c0f4e7cbb7080557d32fd045e6608d8acbf98cf7c16834ed0c5de2ce9d9d5dfa0194d055642276'
- 'fde8546c08c6450f92bd1d327084bd81d899915674832cea754a5fb62f677a12b06428149c5beb1bd51582b174f59e2033af438deb22f4d8842e6ac9d7b496f2'
- '6b57a66b870b2f525e2dedd8f224b89474fd4ec6ea18484b0a67a1a2b9a4fc95d025cac181504406ea42a35d6c1b184c0d4e38c92815022935fc55746c69c7c1'
- '2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
- '8742e2eed421e2f29850e18616f435536c12036ff793f5682a3a8c980cf5dbfc88d17fd9539c87de15d9e4663dc3190f964f18a4722940465437927b6052abbf'
- '2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf')
+ 'fde8546c08c6450f92bd1d327084bd81d899915674832cea754a5fb62f677a12b06428149c5beb1bd51582b174f59e2033af438deb22f4d8842e6ac9d7b496f2')