summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2022-01-11 18:12:34 +0100
committerPiotr Gorski2022-01-11 18:12:34 +0100
commitb8c686b98e701247bf998c72d1eaf728c70faef8 (patch)
tree37c956a79f956fa614e47f3a532bcc4548d00ce5 /PKGBUILD
parentd141f4b4bb1723eea7afbcda918439084ccd7a58 (diff)
downloadaur-b8c686b98e701247bf998c72d1eaf728c70faef8.tar.gz
Add 5.16 line
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdc1d79cd13e..d8eb38040e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20211224.r0.gea586a076e8a
+pkgver=20220111.r0.ga70bf4a85b43
_srcname=linux-next
pkgrel=1
pkgdesc='Linux NEXT'
@@ -58,12 +58,12 @@ options=('!strip')
makedepends=('kmod' 'bc' 'libelf' 'git' 'pahole' 'cpio' 'perl' 'tar' 'xz')
#makedepends=('kmod' 'bc' 'libelf' 'git' 'python-sphinx' 'python-sphinx_rtd_theme'
# 'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz')
-_lucjanver=5.15
+_lucjanver=5.16
#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_lucjanver}"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_lucjanver}"
source=("git://git.kernel.org/pub/scm/linux/kernel/git/next/${_srcname}.git"
- "${_lucjanpath}/arch-patches/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
+ "${_lucjanpath}/arch-patches-sep/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
# the main kernel config files
'config')
@@ -211,12 +211,11 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -309,5 +308,5 @@ for _p in "${pkgname[@]}"; do
done
sha512sums=('SKIP'
- '4d78cc5cfad2a5a9e26f350e28a0f059464f75c2f9d4e4140f0869775bd73c916ac8bd5d68c30aa5688227193885d94264abb1a571c20dec58bd1514c0bec31d'
- '599b0d857fc6cee7853dd85a71157eae764bd5b369e5b1501a79d52eae4b14a6503197204589f160a8a8588e97e4be2a5f26c2e847a5344bfe5690a5c21486fe')
+ '1f090ff2773bc595b488a6201a625f5ccfccd87c50eac603f86aea3d84ecf5e9da3c719da460b60956026e4d9ac9280402cbe45a27d7e7f851b92d4c04986cb5'
+ '1d637eae88d6d2bfd6ca4b0af649f6f1d19f4be5c7cd0ad82d70eb16f08caa581da922af723285d0231595e04aa3f835370d7c8acdf759f53bb21cfd2c754d63')