summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Appelman2018-10-06 13:41:23 +0200
committerRobin Appelman2018-10-06 13:41:23 +0200
commit08dd9fa353e4ae2cc4f7bf39ebaad10d8e5f5499 (patch)
tree39342c1a7382eaf24b358edb28f0c3c778b637f8 /PKGBUILD
parent83f13275bc95b9e145fba11f422c9ed065ec3adf (diff)
downloadaur-08dd9fa353e4ae2cc4f7bf39ebaad10d8e5f5499.tar.gz
update to 4.18.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 25 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70bbb0297132..68b7b33b7f48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
-# $Id$
# nopsp change: Robin Appelman <robin@icewind.nl>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
-pkgbase=linux-nopsp # Build stock -ARCH kernel
+pkgbase=linux-nopsp # Build stock -ARCH kernel, without AMD's PSP
#pkgbase=linux-custom # Build kernel with a different name
-_srcver=4.18.5-arch1
+_srcver=4.18.12-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git)
+makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
options=('!strip')
_srcname=archlinux-linux
source=(
@@ -28,7 +27,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'e357d183c7987dba9c611ca61f69e20c1de39bcc60c78e4ebc3957021c5f2b67'
+ '7313fbe7546d4bb9a1a4353f68bc909f7a3ff8e660bd72dcd8d26da0487787bd'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -63,7 +62,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -193,6 +192,10 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -208,6 +211,22 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}