summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjörn Bidar2016-02-13 16:47:11 +0100
committerBjörn Bidar2016-02-13 16:47:11 +0100
commitef6ee80ccb2a5db825625083f45ff998b232a65d (patch)
tree5b6e6a703f7c7ebf7104e615aa863bf2fc1c70a4 /PKGBUILD
parentac2f6ab58510b4cb0e4372aa53169ef0d3e9288f (diff)
downloadaur-ef6ee80ccb2a5db825625083f45ff998b232a65d.tar.gz
real upkg, there was some error with the last commit that this changes were missing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 30 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ef83e9f9248..9689c715ffd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Some lines from kernel26-bfs and kernel26-ck
# Credits to respective maintainers
_major=4
-_minor=3
+_minor=4
#_patchlevel=0
#_subversion=1
_basekernel=${_major}.${_minor}
_srcname=linux-${_major}.${_minor}
pkgbase=linux-pf
-_pfrel=1
+_pfrel=4
_kernelname=-pf
_pfpatchhome="http://pf.natalenko.name/sources/${_basekernel}/"
_pfpatchname="patch-${_basekernel}${_kernelname}${_pfrel}"
@@ -72,7 +72,7 @@ _BATCH_MODE=n
pkgname=('linux-pf')
true && pkgname=('linux-pf' 'linux-pf-headers')
pkgver=${_basekernel}.${_pfrel}
-pkgrel=2
+pkgrel=1
arch=('i686' 'x86_64')
url="http://pf.natalenko.name/"
license=('GPL2')
@@ -83,7 +83,11 @@ source=("ftp://www.kernel.org/pub/linux/kernel/v${_major}.x/linux-${_basekernel}
'linux.preset' # standard config files for mkinitcpio ramdisk
'change-default-console-loglevel.patch'
"${_pfpatchhome}${_pfpatchname}.xz" # the -pf patchset
- "git+$_aufs3#branch=aufs4.3"
+ "git+$_aufs3#branch=aufs4.4"
+ '0001-sdhci-revert.patch'
+ 'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
+ '0001-4.4-revert-btrfs.patch'
+ '0001-4.4-revert-xfs.patch'
)
# 'cx23885_move_CI_AC_registration_to_a_separate_function.patch'
@@ -130,7 +134,19 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
-
+ # revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
+ # fixes #47778 sdhci broken on some boards
+ # https://bugzilla.kernel.org/show_bug.cgi?id=106541
+ patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
+
+ # fixes #47805 kernel panics on platform modules
+ # https://bugzilla.kernel.org/show_bug.cgi?id=110751
+ patch -Np1 -i "${srcdir}/tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch"
+
+ # #47757 fix broken suspend from btrfs and xfs
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-xfs.patch"
+ patch -Np1 -i "${srcdir}/0001-4.4-revert-btrfs.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -695,10 +711,14 @@ package_linux-pf-headers() {
pkgdesc="Linux kernel and modules with the pf-kernel patch [-ck patchset (BFS included), TuxOnIce, BFQ] and aufs3"
# makepkg -g >>PKGBUILD
-sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
- 'deb12235ebf9285ce778402ff76b3ac948510ba217e3293fa9f27248c370b555'
- '74f174a6780ca9687c5815620df29364c3431c1a2be8917900aed79566977460'
+sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
+ '5f0e331c8eced56d0e0f85a1dc1a42686a606cbd95100a18b8570cce85022c58'
+ 'dc9277eedda6e151f8ce7488f95ba66094775b89e882ad08c06484fe440dcea9'
'82d660caa11db0cd34fd550a049d7296b4a9dcd28f2a50c81418066d6e598864'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '5114f247db30ea4302a12a04ccc5b189c40aa4c4aaf1272bff5d28c6fee84958'
- 'SKIP')
+ '6d59c2433fb4c28fa2635ba96386701d4511a8204b0070b0aa75a8afac7c35c8'
+ 'SKIP'
+ '5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
+ 'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
+ '51586b733e9f178bebe577258b6057b035eded516ffe8bf8bbb26cb0b26c4958'
+ 'ffbfaa192d17bfc7c6293aa9a07efe57f65177051ae3d8033d5e45a7bca2e0ad')