summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2022-01-19 05:32:42 -0500
committergraysky2022-01-19 05:33:00 -0500
commitbfcd89501115925a6340838150987ed244226484 (patch)
tree850cce2bd91f5744eb54fe726d83a246638c605b /PKGBUILD
parent29c5b624caba7488f9ab2d3b66ef3bf1e3be035d (diff)
downloadaur-bfcd89501115925a6340838150987ed244226484.tar.gz
Update to 5.16.2rc1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 12 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d908b4f113f..c560d219566c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgbase=linux-rc
pkgrel=1
-_srcname=linux-5.15
-_major=5.15
+_srcname=linux-5.16
+_major=5.16
### on initial release this is null otherwise it is the current stable subversion
### ie 1,2,3 corresponding $_major.1, $_major.3 etc
-_minor=12
+_minor=1
_minorc=$((_minor+1))
### on initial release this is just $_major
_fullver=$_major.$_minor
@@ -30,27 +30,21 @@ source=(
https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_fullver.tar.{xz,sign}
config # the main kernel config file
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-PCI-Add-more-NVIDIA-controllers-to-the-MSI-masking-q.patch
- 0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
- 0004-cpufreq-intel_pstate-ITMT-support-for-overclocked-sy.patch
- 0005-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
- 0006-lg-laptop-Recognize-more-models.patch
+ 0002-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ 'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
+ 'C7E7849466FE2358343588377258734B41C31549' # David Runge <dvzrv@archlinux.org>
)
-b2sums=('b1e361c850096e73b6f5ad63828a9f7496b32b142df3bc9a99868f99af99546ca85ddc2335310a8e18152038652d089da5aae7856c4d9af5ffbc3c0ebe4dcbea'
+b2sums=('463b6cc4508e68a2f3bac60d016fe495b749d7ef127d91dfc9e7d3fd8e2e3ca48300befb2ed8b5bacb54266228290c74bb5ee46b4f2218d7ab339a02a9a8d6f5'
'SKIP'
- '6e201ffe5832a998b9bc8f63e9fcbf7f0384d4e4abb1a68c2299b8362b51ddcfbc35639bfc836a84202bec3705f5bca1616396c16daa05d778659d286f63b6a8'
+ '39c5b24f069de76ef838fda68281ead1bcc2c98a5f16d95bb32b1d9eb67cb43aef4ccd80395071dbf64ac7409dfcbd129d923a5c8efd22a4998dfbb7c34996c1'
'SKIP'
- '28540af4732569d0638c4b2525cbc3701aec60330d8ac4b081a62145a20226725c1444521cd750ae9cd18ff0f469ce40f8db451588ba0d85c6e0d388f1d82c3b'
- '2e35925fe5e63273633abed68147d1a7646bbfe7b43bf34b260da3544935b25832374662b8b98e1ae78f0c20b9999416b780aa44cc1dad0a9b9e8b2e08dc0f8e'
- '0f21710afb2100b983487abd932c4fc848c86ea6933b2b1d4d175f3065a6dbfcf639f4664854704859a0f2fbf8bdb68dee9e1df353b7e881192e26fca6e1db27'
- 'e7bb8e8453d8cd67b987d9da90a652541bbb1d54f7e4f8109e95bbe70bc6ce37555fa25d366f7ffc91d1715b749f09b66dee68c48e02c26c61268037757892a7'
- '050735f272c8bc14fd483494105bbead52e62d1679aa921d81129600543684437513b0ac480a874f3bd71550d7c53ae5e361020f7e87012a429dee345cb5a35d'
- '56a0ffef39f1bfb1c5932314df117bbb0da84b14875c9e454eaa0bf45d0cd619d93cc0de0c7bb50d7b35f4dd424a66827c8baf4dcfaf0a22b6495357d5dffdf8'
- '84396061332b4dcc7bf8a08c7cb9ff7c7e326d8f452113b6f51c4e8f224f99450024308f8aed87949ae88e93257a92da04cd066a983ff3af1d1decdf01a5c546')
+ '3c6ff0fd8713cf5f0f0f939e45826bc83a7c4458665ae59094d83c416ae536fd8ed3370dec813d1b442ce727459150a0ef04a001cadb2c5ef7d3e2b01d5849da'
+ '8c06f840512d90c2339066677f1c64c07d1d9b7cd9a7d653fa7be1f806b0c66cb26892db662ef95cb6c27c996aef03566454699cfaa8d620dcb90c1f8f8d8276'
+ '863763c1880921c15f4d931194004461c1cb2bf195bb55ae04777694c15c01542e30d8f221d908b4fbb6a57e7b36e3260a97d67a109af3baeb53d6a85b671dd9')
export KBUILD_BUILD_HOST=archlinux
@@ -164,12 +158,9 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
-
echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include