summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2018-02-10 07:13:39 -0500
committergraysky2018-02-10 07:13:39 -0500
commitdb345e1e5524c9754efc807799b47556ba7648c0 (patch)
tree32b4f2e7763569c7bc54ba2bcc50e2457a090ad4 /PKGBUILD
parent603a6bb36d1800735bdee08d7c8b4f01cd6b5f06 (diff)
downloadaur-db345e1e5524c9754efc807799b47556ba7648c0.tar.gz
Update to 4.15.3rc1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 29 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b98bcca1849b..a362c8d6a7a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase=linux-rc
_srcname=linux-4.15
-_stable=4.15.1
-_patchver=4.15.2
+_stable=4.15.2
+_patchver=4.15.3
_rcver=1
pkgver=${_patchver}rc${_rcver}
_rcpatch=patch-${_patchver}-rc${_rcver}
@@ -16,18 +16,19 @@ license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "http://www.kernel.org/pub/linux/kernel/v4.x/patch-${_stable}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${_stable}.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/$_rcpatch.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/$_rcpatch.sign"
- 'config' # the main kernel config file
- '60-linux.hook' # pacman hook for depmod
- '90-linux.hook' # pacman hook for initramfs regeneration
- 'linux.preset' # standard config files for mkinitcpio ramdisk
+ https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz
+ https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign
+ config # the main kernel config file
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
+ http://www.kernel.org/pub/linux/kernel/v4.x/patch-${_stable}.xz
+ https://www.kernel.org/pub/linux/kernel/v4.x/patch-${_stable}.sign
+ https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/$_rcpatch.xz
+ https://www.kernel.org/pub/linux/kernel/v4.x/stable-review/$_rcpatch.sign
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -35,16 +36,17 @@ validpgpkeys=(
)
sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
'SKIP'
- '202a0a34f221ae335de096c292927d7a7d4bcdbc2dd46d43b8a5f6420f95a0cf'
- 'SKIP'
- '2ad4bdc897fc4a13def5ecc79595d5021c61165fffd677074fdc239a4c335f1a'
- 'SKIP'
- 'd7fccd62a83ea0077ba839554e5b59640e9cb52de9c5e061229842beae588c39'
+ '699ad86e5c6076fc5c544d72191efb7eb302f68169dad8495add0f1d156203ab'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '7b7363b53c68f52b119df994c9c08d4f29271b408f021366ab23f862518bd9bc'
- 'ac996455cddccc312d93e63845d92b2d8ab8fb53208a221948d28c76c678d215')
+ 'b20e25656c9423591afd0325fe26320f50bc3421ff204acbfe5dd88ffb3866fe'
+ '68575230693b374eb68e6100e719c71a196db57fe0ac79ddae02fe72b404e09e'
+ 'b21406c060cf601f879528cfa1b83f524c44d8ecd99689c331a7c6326653d0be'
+ '812499c5d0cc5183606dc9388084df162ca2eb5fa374d8f8b00136fd82825847'
+ 'SKIP'
+ '851ca3ea0d4fb450afaced1a513dad8228f282cbd8863537e902e6d947bafaae'
+ 'SKIP')
_kernelname=${pkgbase#linux}
@@ -67,15 +69,16 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
- cp -Tf ../config .config
+ # https://bugs.archlinux.org/task/57327
+ patch -Np1 -i ../0003-ssb-Do-not-disable-PCI-host-on-non-Mips.patch
- if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
- sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
- fi
+ cat ../config - >.config <<END
+CONFIG_LOCALVERSION="${_kernelname}"
+CONFIG_LOCALVERSION_AUTO=n
+END
# set extraversion to pkgrel
- sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
+ sed -i "/^EXTRAVERSION =/s/=.*/= -${pkgrel}/" Makefile
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -121,7 +124,7 @@ _package() {
cp arch/x86/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# make room for external modules
- local _extramodules="extramodules-${_basekernel}${_kernelname:--ARCH}"
+ local _extramodules="extramodules-${_basekernel}${_kernelname}"
ln -s "../${_extramodules}" "${pkgdir}/usr/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from hook