summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Chirstoforo2016-03-10 10:38:28 +0000
committerGrey Chirstoforo2016-03-10 12:21:41 +0000
commit00c399e9e28f58910b5a82a1bd1ee7b101460a81 (patch)
tree5fd190608784b3de8cbada564a8e35743e72a516 /PKGBUILD
parent8b020ca38adb24508802758a7e89cf52c2beaa2f (diff)
downloadaur-00c399e9e28f58910b5a82a1bd1ee7b101460a81.tar.gz
add git commit hash to package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5226a600e3d..bf031565a329 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,8 @@ prepare() {
pkgver() {
cd linux
RELEASE=$(make kernelrelease)
- echo ${RELEASE//[-]/_}
+ RELEASE=${RELEASE//[-]/_}
+ printf "%s.%s" "$RELEASE" "$(git rev-parse --short HEAD)"
}
build() {