summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Chirstoforo2016-03-08 22:17:46 +0000
committerGrey Chirstoforo2016-03-08 22:17:46 +0000
commitd438b2082137603018fdfb02f558f461b5a6583d (patch)
treecb2958cffe88391db9dbe76556ed9c29e7e449ad /PKGBUILD
parent07c92c8fd112557cc3822f448712a4d3692eefd6 (diff)
downloadaur-d438b2082137603018fdfb02f558f461b5a6583d.tar.gz
add config overrides
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a680947bc48b..189cc98baa43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("linux::git://github.com/raspberrypi/linux#branch=rpi-${_branch}.y"
'config.txt'
- 'cmdline.txt')
+ 'cmdline.txt'
+ 'config.overrides')
md5sums=('SKIP'
'e44f530b3d333b98ad376872cdbbf823'
- '0244ab7cb2e385a8efe9a7fba9bfcb48')
+ '0244ab7cb2e385a8efe9a7fba9bfcb48'
+ '52d6ecfbfbd617c05324d0e6cd2d7d18')
_dirname=linux-${_branch}
_kernelname=${pkgbase#linux}
pkgver=4.5.0_rc7_1_v7+
@@ -29,6 +31,9 @@ prepare() {
KERNEL=kernel7
make bcm2709_defconfig
+ # override some .config settings
+ scripts/kconfig/merge_config.sh -r .config ../config.overrides
+
# add pkgrel to extraversion
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile