summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Chirstoforo2016-03-10 10:38:28 +0000
committerGrey Chirstoforo2016-03-10 12:21:15 +0000
commit23e4ebe26c02dd40ab990fe249e1766f448c85f7 (patch)
tree1ff6a5f010e54285e13d009fac9a74b8d5e6977d /PKGBUILD
parent9b406799d64fc373c9c13bac0b18628288090762 (diff)
downloadaur-23e4ebe26c02dd40ab990fe249e1766f448c85f7.tar.gz
add git commit hash to package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31927ee28401..2c3389733816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,8 @@ prepare() {
pkgver() {
cd linux
RELEASE=$(make kernelrelease)
- echo ${RELEASE//[-]/_}
+ RELEASE=${RELEASE//[-]/_}
+ printf "%s.%s" "$RELEASE" "$(git rev-parse --short HEAD)"
}
build() {