summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoakim Hernberg2018-01-26 13:56:55 +0100
committerJoakim Hernberg2018-01-26 13:56:55 +0100
commit200704e3ea9a97d33c05a5abb8c6906cc60cf826 (patch)
tree445b9875cc15dd740b491de349412860fb28d60a /PKGBUILD
parent00e127955bf20402770cf57e16723a77544d961c (diff)
downloadaur-200704e3ea9a97d33c05a5abb8c6906cc60cf826.tar.gz
bump to 4.14.15_rt12-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 11 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f465d8189f9..e6c6413807ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
#pkgbase=linux # Build stock -ARCH kernel
pkgbase=linux-rt # Build kernel with a different name
_srcname=linux-4.14
-_pkgver=4.14.12
-_rtpatchver=rt10
+_pkgver=4.14.15
+_rtpatchver=rt12
pkgver=${_pkgver}_${_rtpatchver}
pkgrel=1
arch=('x86_64')
@@ -29,11 +29,9 @@ source=(
'90-linux-rt.hook' # pacman hook for initramfs regeneration
'linux-rt.preset' # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
- 0003-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
- 0004-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
- 0005-cgroup-fix-css_task_iter-crash-on-CSS_TASK_ITER_PROC.patch
- 0006-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
+ 0003-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
+ 0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch
)
validpgpkeys=(
@@ -45,19 +43,17 @@ validpgpkeys=(
)
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'SKIP'
- 'da5d8db44b0988e4c45346899d3f5a51f8bd6c25f14e729615ca9ff9f17bdefd'
+ '54a6359ed333e619db8c5c88020ff20f1e25635337f01f50a7488ec2fc0fe030'
'SKIP'
- '254a13ec6e835796d86b627346dbc13dd7b9e7cca76300ebe3617a5207d4ea10'
+ '76e6628c22b80ea7e6aaea028bd91847eb2e7819e1887ea3a6a5f19dd661e261'
'SKIP'
- '0609e14c5010e59ad6ae58399f12b8872c9d8e2cd3a87e3b9f14007b2adaa13c'
+ '8ff52002e8b6b2ec628fc699ff32c989ddc07b59587b73211c5fba6d897eb599'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'd8a865a11665424b21fe6be9265eb287ee6d5646261a486954ddf3a4ee87e78f'
- '9251c03da9d4b64591d77f490ff144d4ba514e66e74294ada541bf827306c9c4'
'6ce57b8dba43db4c6ee167a8891167b7d1e1e101d5112e776113eb37de5c37d8'
'1c1f5792c98369c546840950e6569a690cd88e33d4f0931d2b0b5b88f705aa4d'
- 'c3d743a0e193294bc5fbae65e7ba69fd997cd8b2ded9c9a45c5151d71d9cfb95'
'ec7342aab478af79a17ff65cf65bbd6744b0caee8f66c77a39bba61a78e6576d'
'85f7612edfa129210343d6a4fe4ba2a4ac3542d98b7e28c8896738e7e6541c06')
@@ -78,20 +74,14 @@ prepare() {
# disable USER_NS for non-root users by default
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- # https://bugs.archlinux.org/task/56575
- patch -Np1 -i ../0002-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
-
# https://nvd.nist.gov/vuln/detail/CVE-2017-8824
- patch -Np1 -i ../0003-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
+ patch -Np1 -i ../0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
# https://bugs.archlinux.org/task/56605
- patch -Np1 -i ../0004-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
-
- # https://bugs.archlinux.org/task/56846
- patch -Np1 -i ../0005-cgroup-fix-css_task_iter-crash-on-CSS_TASK_ITER_PROC.patch
+ patch -Np1 -i ../0003-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
# https://bugs.archlinux.org/task/56711
- patch -Np1 -i ../0006-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ patch -Np1 -i ../0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
# add realtime patch
msg "applying patch-${_pkgver}-${_rtpatchver}.patch"