summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2018-12-02 18:51:22 +0100
committerPiotr Gorski2018-12-02 18:51:22 +0100
commit33f0ff36f9e6424699ba07ced59dfe308521453f (patch)
tree21088b6058444bc74a99ed0bc15402151625873c /PKGBUILD
parent2c466040db63f18660455834e0b2d5ac463cda5d (diff)
downloadaur-33f0ff36f9e6424699ba07ced59dfe308521453f.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a918c00927d6..a33cc71356c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,9 +31,7 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -60,7 +58,7 @@ pkgver=${_major}.${_minor}.${_rtver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
_rtpatchver=rt${_rtver}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -173,11 +171,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ msg2 "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
make localmodconfig
fi
fi