summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsirlucjan2015-09-18 18:11:26 +0200
committersirlucjan2015-09-18 18:11:26 +0200
commite1d0558ffde196c905d90ca50ab76391c54aa971 (patch)
tree24ad580e171fab628c49946640ad8b6fee35d58e /PKGBUILD
parent13c190eb73a518d9dd8b546d61519007b4784105 (diff)
downloadaur-e1d0558ffde196c905d90ca50ab76391c54aa971.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfc70eea8046..0a3d3d6c976e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,9 @@ _makexconfig=
# Tweak kernel options prior to a build via gconfig
_makegconfig=
+# Running with a 1000 HZ tick rate
+_1k_HZ_ticks=
+
# NUMA is optimized for multi-socket motherboards.
# A single multi-core CPU actually runs slower with NUMA enabled.
# See, https://bugs.archlinux.org/task/31187
@@ -122,8 +125,14 @@ prepare() {
cat "${srcdir}/config" > ./.config
fi
+ ### Optionally set tickrate to 1000
+ if [ -n "$_1k_HZ_ticks" ]; then
+ msg "Setting tick rate to 1k..."
+ sed -i -e 's/^CONFIG_HZ_300=y/# CONFIG_HZ_300 is not set/' \
+ -i -e 's/^# CONFIG_HZ_1000 is not set/CONFIG_HZ_1000=y/' \
+ -i -e 's/^CONFIG_HZ=300/CONFIG_HZ=1000/' .config
+ fi
-
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
if [ -n "$_use_current" ]; then