summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2020-04-07 11:03:45 +0200
committerDavid Runge2020-04-07 11:03:45 +0200
commitea05b30f574ccc9828c1f888d4ad45b8fc744547 (patch)
tree1da766faa72d083987c644c94147dc0862d8d565 /PKGBUILD
parentbf2e16151436985386f3cd419fd6fe8cf123da2f (diff)
downloadaur-ea05b30f574ccc9828c1f888d4ad45b8fc744547.tar.gz
PKGBUILD: Addin patch for python-sphinx.
Cleaning up the build script to be in line with current core/linux-lts. Simplifying the discovery of the RT patch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ddeeb89b515..1e8ef86dde02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,12 @@ _pkgver=4.19.106
_rtpatchver=46
pkgbase=linux-rt-lts
pkgver=${_pkgver}.${_rtpatchver}
-pkgrel=1
+pkgrel=2
+pkgdesc='Linux RT LTS'
arch=('x86_64')
url="https://wiki.linuxfoundation.org/realtime/start"
license=('GPL2')
-makedepends=('bc' 'git' 'graphviz' 'imagemagick' 'inetutils' 'kmod' 'libelf'
+makedepends=('bc' 'git' 'graphviz' 'imagemagick' 'kmod' 'libelf'
'python-sphinx' 'python-sphinx_rtd_theme' 'xmlto')
options=('!strip')
_srcname=linux-${_pkgver}
@@ -43,10 +44,6 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
- # apply realtime patch
- msg "applying patch-${_pkgver}-rt${_rtpatchver}.patch"
- patch -Np1 -i "../patch-${_pkgver}-rt${_rtpatchver}.patch"
-
echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
@@ -56,27 +53,34 @@ prepare() {
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
+ # picking up the RT patch
+ src="${src//patch.xz/patch}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
done
+ # removing cdomain configuration (incompatible with python-sphinx >= 3.0.0):
+ # https://github.com/sphinx-doc/sphinx/issues/7421
+ sed -e "s/'cdomain',//" -i Documentation/conf.py
+
echo "Setting config..."
cp ../config .config
make olddefconfig
# make menuconfig # CLI menu for configuration
make -s kernelrelease > version
- echo "Prepared %s version %s" "$pkgbase" "$(<version)"
+ echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
- make bzImage modules htmldocs
+ make all
+ make htmldocs
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
@@ -104,7 +108,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -122,7 +126,7 @@ _package-headers() {
# add xfs and shmem for aufs building
mkdir -p "$builddir"/{fs/xfs,mm}
- # this is gone in v5.3
+ # TODO: remove with linux > 5.3
mkdir "$builddir/.tmp_versions"
echo "Installing headers..."
@@ -185,7 +189,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Documentation for the $pkgdesc kernel"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"