summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2018-04-22 15:50:40 +0200
committerNicolas Iooss2018-04-22 15:50:40 +0200
commit105cb7d87bde15fe2ab7b767265a269d16be9d9a (patch)
tree3edcb4053c2af5b5a9d05e412678dfb826dca821 /PKGBUILD
parent9291dbbb0826ebe754ab32a4a7aca99c06478953 (diff)
downloadaur-105cb7d87bde15fe2ab7b767265a269d16be9d9a.tar.gz
linux-selinux 4.16.3-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d402374b5f24..b9a00065f087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgbase=linux-selinux
-_srcname=linux-4.15
-pkgver=4.15.15
+_srcname=linux-4.16
+pkgver=4.16.3
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -22,21 +22,29 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ 0003-Partially-revert-swiotlb-remove-various-exports.patch
+ 0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
+ 0005-Revert-drm-amd-display-disable-CRTCs-with-NULL-FB-on.patch
+ 0006-net-aquantia-Regression-on-reset-with-1.x-firmware.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769'
+sha256sums=('63f6dc8e3c9f3a0273d5d6f4dca38a2413ca3a5f689329d05b750e4c87bb21b9'
'SKIP'
- 'd8e7f93e24db5517a1be2030a765431120e07f7cd55e510d0de562c70e45bc00'
+ '336252cb15f2f2574461c1d3daabf5dc207842526085802270e1e5223f645db3'
'SKIP'
- '6ea31b5de2ac181fa9e6724a6e3dff58b1177670f273f4bd3226ddfae5c5cd90'
+ '611a43d17b8d8b3d0a1c73921fd1a551e430b4dd3af23aeefe5bd5ff19d2a17c'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '4ffdc2a458845c2a7c03c735477dbf51b5b01b10568bf577b37a29e872135cab'
- '12b281dc45f1954cc3f52276927bb2965c3132c0a8bd7f485869ced2c541d485')
+ 'a6119b46856ed2652c509fed380052e6df2be89c69a0d748cf7d8745bf35b871'
+ '545566a7358d711b8d4f9924df685e2410549e20d99e5d1c0dfaccdfeafda60d'
+ 'bef6dd7b3a749ec072614ea4ed0bd5ea1d90519731f3438e4938d5b957032cc5'
+ 'd647211e288436bcc010019a69f4ebf9a94c33b423c650aea8098969208ec836'
+ '6fb4fb81dab69ff432767e02585b3eb6a5a39c941e4bc2a6d4940ee17116c14e'
+ 'd49a70d3b3f60c81d93735871f01ea60cafca87588d8d0d01801b2aec92e0e93')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -56,6 +64,18 @@ prepare() {
# https://bugs.archlinux.org/task/56711
patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ # NVIDIA driver compat
+ patch -Np1 -i ../0003-Partially-revert-swiotlb-remove-various-exports.patch
+
+ # https://bugs.archlinux.org/task/58153
+ patch -Np1 -i ../0004-Fix-vboxguest-on-guests-with-more-than-4G-RAM.patch
+
+ # https://bugs.archlinux.org/task/58158
+ patch -Np1 -i ../0005-Revert-drm-amd-display-disable-CRTCs-with-NULL-FB-on.patch
+
+ # https://bugs.archlinux.org/task/58174
+ patch -Np1 -i ../0006-net-aquantia-Regression-on-reset-with-1.x-firmware.patch
+
cat ../config - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"
CONFIG_LOCALVERSION_AUTO=n
@@ -173,9 +193,6 @@ _package-headers() {
install -Dt "${_builddir}/drivers/md" -m644 drivers/md/*.h
install -Dt "${_builddir}/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/9912
- install -Dt "${_builddir}/drivers/media/dvb-core" -m644 drivers/media/dvb-core/*.h
-
# http://bugs.archlinux.org/task/13146
install -Dt "${_builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h